Bug 113940 - Fedora Core 1 x86_64 doesn't detect SATA drives on Via controller
Fedora Core 1 x86_64 doesn't detect SATA drives on Via controller
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 09:59 EST by ammulder
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 23:33:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ammulder 2004-01-20 09:59:14 EST
Description of problem:

Computer has 2 IDE drives, 1 SATA drive.  Want to install to SATA
drive.  Boot with Fedora Core Test 1 for x86_64 disc 1.  When I get to
the partitioning screen, it only shows the 2 IDE drives (no SATA
drive).  On another system where I was sent to the manual driver
selection screen, there did not appear to be an option for "sata_via",
which is the desired driver.

Steps to Reproduce:
1. Configure computer with both IDE & SATA drives
  
Actual results:

Only IDE drives visible for partitioning

Expected results:

SATA drive visible too

Additional info:

Motherboard is Asus K8V Deluxe.  It has 2 SATA controllers, one Via
(8237 if memory serves), and the other Promise.  Both are RAID/IDE
controllers.  Single SATA drive on Via controller.  "sata_via" driver
worked for this drive under SuSE 9.0 for AMD64.

I am especially confused as the FAQ for this release said Via and
Promise SATA support was there.
Comment 1 Justin M. Forbes 2004-01-20 14:21:01 EST
Some Via chipsets are supported with the libata update.  It is my
understanding on that particular board, the promise controllers will
work.  SATA is a work in progress, and was not originally part of FC1,
drivers are being implemented as they are working upstream, but
support will be spotty for a while.
Comment 2 James Henstridge 2004-01-27 08:15:01 EST
The modules.cgz file in the install image doesn't seem to include the
sata_*.o modules, which is probably part of the reason it didn't get
detected.  It does include libata.o though.

I reported a similar bug about the promise drivers as bug 114365,
which might be considered a duplicate.
Comment 3 James Henstridge 2004-01-27 22:59:29 EST
I managed to work around the similar problem I was having (with a
Promise SATA controller, rather than VIA).

Assuming that the problem with the VIA controller is the same, then
this is a problem with the installer rather than the kernel (if you
manage to get it installed, and have a correct initrd, you should be
able to boot).
Comment 4 Justin M. Forbes 2004-03-06 02:21:58 EST
This should be fixed in release... Possible to verify? Should this be
closed?
Comment 5 Justin M. Forbes 2004-03-10 23:33:54 EST
closing this one, works for me on both via and promise under FC1 release.

Note You need to log in before you can comment on or make changes to this bug.