Bug 113944 - AMD 8151 AGP Missing for Fedora Core 1 for x86_64
AMD 8151 AGP Missing for Fedora Core 1 for x86_64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 10:27 EST by ammulder
Modified: 2015-01-04 17:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 20:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ammulder 2004-01-20 10:27:22 EST
Description of problem:

AGP support is compiled into the kernel for Fedora Core 1 Test 1 for
x86_64.  Apparently, AMD 8151 support was not included.  dmesg output
includes "agpgart: no supported devices found.".  SuSE 9.0 for AMD64
includes AMD 8151 support and correctly identifies the AGP bus during
kernel loading.

Steps to Reproduce:
1. boot
2. examine dmesg output
  
Actual results:

No AGP support

Expected results:

AGP support

Additional info:

Tyan Thunder K8W board, Nvidia GeForce 4 4600.  AMD web site claims
8151 support has been availabe in the kernel for some time now. 
Probably just needs to be compiled in.
Comment 1 Dave Jones 2004-01-20 10:42:54 EST
support is there, but due to a bug, it doesn't pick up the agp bridge
on the tyan board (its in a different place to other amd64 boards).
The fix for this is in the current -testing kernel (2163).
Comment 2 Justin M. Forbes 2004-01-20 14:25:48 EST
The Tyan board specifically has the AGP bridge tied to CPU1 instead of
CPU0.  While this should be a performance improvement in the future,
it will take a while for everyone to understand the implications of
that choice. Specifically, while the testing kernel will identify the
AGPGart, it is my understanding that the nVidia drivers still will not
function in this configuration. They are working on the problem.

Note You need to log in before you can comment on or make changes to this bug.