Bug 113945 - Unable to compile Nvidia driver on x86_64
Summary: Unable to compile Nvidia driver on x86_64
Status: CLOSED DUPLICATE of bug 73733
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-20 15:34 UTC by ammulder
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X Config File (7.38 KB, text/plain)
2004-01-20 15:36 UTC, ammulder
no flags Details
X Log File (44.45 KB, text/plain)
2004-01-20 15:36 UTC, ammulder
no flags Details

Description ammulder 2004-01-20 15:34:32 UTC
Description of problem:

Downloaded Nvidia driver for AMD64.  Tried to compile the kernel
module.  Got error:

"You appear to be compiling the NVIDIA kernel module with a compiler
different from the one that was used to compile the running kernel..."

I can override this by setting an env var. When I do that, when
starting X-Windows with this driver, it immediately crashes with no
obvious error.

Actual results:

Nvidia installer complains, when forced, X crashes on startup.

Expected results:

Driver compiles successfully and works fine.

Additional info:

gcc -v reports 3.3.2 20031022 (Red Hat Linux 3.3.2-1)

Using XF86Config file that worked under Red Hat 9 and SuSE 9.0 for
AMD64 on the same machine (and driver compiled without complaints on
both those platforms)

Comment 1 Arjan van de Ven 2004-01-20 15:35:54 UTC

*** This bug has been marked as a duplicate of 73733 ***

Comment 2 ammulder 2004-01-20 15:36:03 UTC
Created attachment 97124 [details]
X Config File

Comment 3 ammulder 2004-01-20 15:36:32 UTC
Created attachment 97125 [details]
X Log File

Comment 4 Red Hat Bugzilla 2006-02-21 19:00:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.