This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11396 - "ls" consumes all memory and dies
"ls" consumes all memory and dies
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-12 18:18 EDT by olchansk
Modified: 2012-08-30 14:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 17:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description olchansk 2000-05-12 18:18:34 EDT
We get this error from "ls":
------
root# ls -f
ls: Memory exhausted
root#
------
with "top" and "xosview" we see that "ls" grows until
it consumes all available memory (256 Mbytes) and dies
with the above error.

The directory with this problem is NFS mounted from
an SGI running IRIX 6.5.7m. The directory is located
on an XLV logical volume and contains about 2000 files.
Other directories with fewer files seem to be fine.

Further details on mount options, disk sizes, etc...
are available upon request to olchansk@bnl.gov

K.O.
Comment 1 Bernhard Rosenkraenzer 2000-06-12 17:45:34 EDT
Looks like an interoperability bug between the nfs implementations in the
kernel.
reassigning.
Comment 2 Alan Cox 2000-08-08 17:23:10 EDT
Known SGI problem. They sometimes duplicate directory keys and that causes an
infinite directory size!

Note You need to log in before you can comment on or make changes to this bug.