Bug 113962 - usb keyboard does not work when installing
usb keyboard does not work when installing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 13:56 EST by Christian Nabski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 04:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nabski 2004-01-20 13:56:39 EST
Description of problem:

When you boot the CD and enter the install (boot the kernel) the USB
keyboard (and mouse ?) does not work.
This quite necessary on an USB only system :-) 
Hardware is :
IBM Eseries 325 1U Dual opteron 2ghz CPU 
No ps/2 ports available 


Version-Release number of selected component (if applicable):


How reproducible:

Boot the fedora test1 AMD64 cd and type enter (or linux) at the
install prompt.
After this the USB devices do not work. Not able to choose skip or ok
at the prompt for the cd check.

Steps to Reproduce:
1. Boot cd
2. Type enter
3. Try to choose ok in cd check dialog
  
Actual results:


Expected results:


Additional info:
Comment 1 Justin M. Forbes 2004-03-04 01:06:53 EST
you might look for a bios update on this one, x325 with current
firmwares seems to install fine on test1.
Comment 2 JP 2004-05-07 02:38:05 EDT
I'm having the same problem on Fedora 2 test 3 with a Chaintech 7VIF4
based system.  I have the latest firmware (2.0 2003/09/08).  I've
tried enabling and disabling the USB keyboard support in the bios and
neither works.

Could the problem be keyboard dependent?  I'll see if I can try
another one.

It's the exact same problem as described above.  I'm unable to enter
anything on the keyboard at the "check cd" prompt.

If I try installing with a PS2 keyboard everything works fine. The USB
worked fine to install Windows XP.
Comment 3 Jeff Lawson 2004-08-29 15:31:41 EDT
This also occurs for me on Tyan S2880 AMD Opteron (x86_64), with the
most current BIOS available from Tyan.  I need to use USB keyboard
because the PS/2 ports on my system are no longer functional.  I have
tried this most recently on Fedora Core 2.

Please note that the BIOS USB keyboard support works fine at the
initial LILO boot prompt, but once the kernel boots and asks for input
at the
"check cd" prompt the keyboard support stops working.

I cannot even use the VNC install option, since the "check cd" prompt
is apparently done before connecting by VNC becomes an option.

Note You need to log in before you can comment on or make changes to this bug.