Bug 1139659 - RFE: libvirt should support the ssh driver
Summary: RFE: libvirt should support the ssh driver
Keywords:
Status: CLOSED DUPLICATE of bug 1140166
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Krempa
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1140166
TreeView+ depends on / blocked
 
Reported: 2014-09-09 11:44 UTC by Richard W.M. Jones
Modified: 2016-04-10 14:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1140166 (view as bug list)
Environment:
Last Closed: 2016-04-10 14:21:13 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-09-09 11:44:56 UTC
Description of problem:

Note this requires that you have fixed bug 1134592 in libvirt first.

If you create a backing file that references an ssh server,
libvirt doesn't pass the required SSH_* variables through to
qemu so it cannot access the ssh agent.

$ qemu-img create -f qcow2 \
  -b 'json: { "file.driver":"ssh",
              "file.path":"/mnt/scratch/test1.img",
              "file.user":"rjones",
              "file.host":"onuma.home.annexia.org",
              "file.host_key_check":"no" }' test2.img

$ ~/d/libvirt/run guestfish -a test2.img run
[...]
Original error from libvirt: internal error: early end of file from monitor: possible problem:
2014-09-09T11:36:32.304954Z qemu-system-x86_64: -drive file=/tmp/test2.img,if=none,id=drive-scsi0-0-0-0,format=qcow2,cache=writeback: could not open disk image /tmp/test2.img: Could not open backing file: failed to connect to ssh-agent: no auth sock variable (libssh2 error code: -39)
 [code=1 domain=10]

Version-Release number of selected component (if applicable):

libvirt from git (2014-09-09) + patches to fix bug 1134592.

How reproducible:

100%

Steps to Reproduce:
1. See above.

Related: bug 856619

Comment 1 Richard W.M. Jones 2014-09-10 12:02:00 UTC
Dan suggests that I make this bug into a more general feature request.

Comment 2 Cole Robinson 2016-04-10 14:21:13 UTC
Just duping to the RHEL bug: if we are tracking this for RHEL then there isn't much use in having a duplicate upstream bug

*** This bug has been marked as a duplicate of bug 1140166 ***


Note You need to log in before you can comment on or make changes to this bug.