Bug 1139764 - Workstation net install results in multi-user.target
Summary: Workstation net install results in multi-user.target
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2014-09-09 15:07 UTC by Paul Whalen
Modified: 2014-09-09 19:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 19:29:49 UTC


Attachments (Terms of Use)
storage log (174.14 KB, text/plain)
2014-09-09 16:36 UTC, Paul Whalen
no flags Details
program log (37.77 KB, text/plain)
2014-09-09 16:36 UTC, Paul Whalen
no flags Details
packaging (509.39 KB, text/plain)
2014-09-09 16:37 UTC, Paul Whalen
no flags Details
journal (1.06 MB, text/plain)
2014-09-09 16:37 UTC, Paul Whalen
no flags Details
ifcfg log (1.39 KB, text/plain)
2014-09-09 16:37 UTC, Paul Whalen
no flags Details
anaconda log (19.20 KB, text/plain)
2014-09-09 16:38 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2014-09-09 15:07:00 UTC
Description of problem:
After Workstation network installation of 21_Alpha_TC6 reboot to multiuser.target.

Version-Release number of selected component (if applicable):
anaconda 21.48.4-1

Expected results:
graphical.target

Additional info:
once the symlink is changed boots to graphical.

Comment 1 David Shea 2014-09-09 15:12:04 UTC
Please attach the log files from /tmp (or /var/log/anaconda on the installed system) to this bug.

Comment 2 Kyle McMartin 2014-09-09 15:13:07 UTC
hrm, the only real obvious way I can see this differing on armv7hl is if:

 618             # XXX one day this might need to account for anaconda's display      mode
 619             if ts.dbMatch("provides", 'service(graphical-login)').count() a     nd \
 620                ts.dbMatch('provides', 'xorg-x11-server-Xorg').count() and \
 621                not flags.usevnc:
 622                 # We only manipulate the ksdata.  The symlink is made later
 623                 # during the config write out.
 624                 self.data.xconfig.startX = True

i guess the question is if service(graphical-login) is provided by something installed?

Comment 3 David Shea 2014-09-09 15:16:47 UTC
The other question would be whether the installation happened graphically. If you requested text during the install, we give you text afterwards, too.

Comment 4 Paul Whalen 2014-09-09 16:36:27 UTC
Created attachment 935819 [details]
storage log

Comment 5 Paul Whalen 2014-09-09 16:36:58 UTC
Created attachment 935820 [details]
program log

Comment 6 Paul Whalen 2014-09-09 16:37:18 UTC
Created attachment 935821 [details]
packaging

Comment 7 Paul Whalen 2014-09-09 16:37:37 UTC
Created attachment 935822 [details]
journal

Comment 8 Paul Whalen 2014-09-09 16:37:57 UTC
Created attachment 935823 [details]
ifcfg log

Comment 9 Paul Whalen 2014-09-09 16:38:19 UTC
Created attachment 935824 [details]
anaconda log

Comment 10 Paul Whalen 2014-09-09 16:39:22 UTC
the logs files attached are from a VNC install, but this also occured with text installation.

Comment 11 Kyle McMartin 2014-09-09 16:57:47 UTC
looks like both text and vnc will result in multi-user.target, and only the full graphical install will result in graphical.target, so i guess it's expected behaviour.

Comment 12 David Shea 2014-09-09 18:35:08 UTC
vnc should get graphical.target, probably. Good news! It's not arm-specific. Text mode is behaving correctly, though.

Comment 13 David Shea 2014-09-09 19:29:49 UTC
Actually, thinking about it a bit more I think I'd rather just leave things the way they are. Installing via VNC usually implies a lack of access to a real console, so installing via VNC and expecting a graphical login at the end is kind of a weird use case. Also the usevnc exception in the block of code that Kyle posted has been there for at least three Fedora releases and this is the first complaint.

Comment 14 Kyle McMartin 2014-09-09 19:30:57 UTC
indeed, i'm fine with it, as long as it's expected and consistent.

regards, kyle


Note You need to log in before you can comment on or make changes to this bug.