Bug 1139780 - Storage node is not stopped during reverted upgrade and second invocation causes BindException
Summary: Storage node is not stopped during reverted upgrade and second invocation cau...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Installer, Upgrade
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Filip Brychta
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-09 15:35 UTC by Filip Brychta
Modified: 2014-12-11 14:02 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:02:39 UTC


Attachments (Terms of Use)
console.log (8.98 KB, text/plain)
2014-09-09 15:35 UTC, Filip Brychta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1035357 None None None Never

Internal Trackers: 1035357

Description Filip Brychta 2014-09-09 15:35:37 UTC
Created attachment 935798 [details]
console.log

Description of problem:
When the upgrade process is reverted due to some error, storage node is not stopped and second upgrade attempt throws ExportException: Port already in use: 7299

Version-Release number of selected component (if applicable):
Version :	
3.3.0.ER02
Build Number :	
4fbb183:7da54e2

How reproducible:
Always

Steps to Reproduce:
1. install jon3.2.0.GA
2. start upgrade to jon3.3.ER2 and cancel it (ctrl+c) during server installation (line: Trying to start the RHQ Server...)
3. start the upgrade again

Actual results:
11:24:13,825 WARN  [org.rhq.storage.installer.StorageInstaller] The storage node reported the following errors while trying to start:

Error: Exception thrown by the agent : java.rmi.server.ExportException: Port already in use: 7299; nested exception is: 
	java.net.BindException: Address already in use

Expected results:
Storage node is stopped after step 2 and no errors are thrown during step 3

Additional info:
See complete console.log

Comment 1 Michael Burman 2014-09-12 07:17:01 UTC
Fixed in master:

commit e53a218269a501f22ec491927a15362fe31159b2
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Sep 12 10:16:25 2014 +0300

    [BZ 1139780] UndoTasks are done in reverse order, so add stop command after the delete command to the undoTask list

Comment 2 Thomas Segismont 2014-09-23 14:57:49 UTC
Cherry-picked over to release/jon3.3.x

commit b1edee142c637181bacb7a6f36576f4934997250
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Sep 12 10:16:25 2014 +0300
    
    (cherry picked from commit e53a218269a501f22ec491927a15362fe31159b2)
    Signed-off-by: Thomas Segismont <tsegismo@redhat.com>

Comment 3 Simeon Pinder 2014-10-01 21:33:12 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 4 Filip Brychta 2014-10-02 10:21:33 UTC
Verified on
Version :	
3.3.0.ER04
Build Number :	
99d2107:d7c537e


Note You need to log in before you can comment on or make changes to this bug.