Bug 113980 - Docs display is whack in production
Docs display is whack in production
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn310
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fanny Augustin
https://rhn.redhat.com/help/
:
Depends On:
Blocks: 108937
  Show dependency treegraph
 
Reported: 2004-01-20 16:50 EST by Clay Murphy
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 18:42:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clay Murphy 2004-01-20 16:50:18 EST
Description of problem:
The display of our documentation within the Help section of the
website is poor and sometimes inaccurate. Here are the issues and
suggested changes:

1. A link to the RHN Provisioning Reference Guide appears regardless
of the entitlement level of the account being used, even when not
logged in at all.
- I suggest presenting it only when the account is
Provisioning-enabled to match the logic behind our display of the RHN
Management Reference Guide, substituting it for the RHN Update (or
Management) Reference Guide, rather than adding to it. No other
reference/service guide needs to be presented, since these are built
off one another and contain virtually all of the same content.

2. Although the PDF link to the RHN Provisioning Reference Guide
works, the HTML link (at least for non-provisioning entitled accounts)
actually goes to the RHN Update Reference Guide.
- I suggest linking to the separate prov. guide at:
https://rhn.redhat.com/help/provisioning/

3. The link to the RHN Update Reference Guide still reads, "RHN User
Reference Guide" giving no indication of the service level to which it
applies.
- I suggest replacing "User" with "Update" to make it more descriptive
and consistent.

4. The buttons to the reference guides in the left navigation bar are
inconsistent. When linked to the Update guide, it reads, "Reference
Guide." When linked to the Management guide, it reads, "Management
Service Guide." When linked to the Provisioning guide, it reads,
"Provisioning Service Guide."
- I suggest presenting only one type of reference guide, depending on
the account entitlement level. (See item 1.) If possible, the button
should read, "Reference Guide" regardless of the type of guide.

Please let me know if you have questions.
Comment 1 Robin Norwood 2004-01-22 16:12:02 EST
Fixed as described above - 

The proper reference guide (and *only* the proper reference guide)
should show up for each kind of user.

The nav will read 'Reference Guide' in all cases.

In CVS
Comment 2 Josef Komenda 2004-01-23 13:21:25 EST
looks good in qa.
Comment 3 Josef Komenda 2004-01-28 18:42:02 EST
Docs now dope. 

Note You need to log in before you can comment on or make changes to this bug.