Bug 113982 - ethtool unable to change parameters on tg3 ethernet driver with kernel-2.4.21-4.EL
ethtool unable to change parameters on tg3 ethernet driver with kernel-2.4.21...
Status: CLOSED DUPLICATE of bug 108115
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-01-20 16:59 EST by Ingvar Hagelund
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2004-01-20 16:59:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
We have a case with a HP Proliant DL 380 G3 (which seems to be noted
as supported by RHEL 3,
http://hardware.redhat.com/hcl/?pagename=details&hid=5257 ). This
machine has two onboard Tigon gigabit ethernet controllers. They seem
to work well with the tg3 driver. When patching one of these with a
switch with hard settings (eg no autonegotiation) 100MBit Full Duplex,
we get problems, as the driver (probably?) will probe for working
modes, and stop at 100MBit Half Duplex, where it detects a working link.

To get Full Duplex, one has to use a tool to force the correct values.
We tried both mii-tool and ethtool. The latter is known to work with
the same machine with earlier RedHat kernels.

Now, we Run ES 3 with the standard installed kernel (tried both up and
smp). With this kernel, running netconf has no impact on the availble
settings at least not the ones we use (speed, autonegotiation, duplex)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect your HP Proliant DL380 G3 Tigon gigabit ethernet port to a
fixed 100MBit Full Duplex switch without autonegotiation
2. Boot up Linux. Take up a network interface
3. Use dmesg or ethtool to look at the duplex mode (half duplex)
reported by the driver. 
4. Try to use netconf to change autonegotiation and duplex mode,
something like this:

ethtool -s eth0 autoneg off
ethtool -s eth0 speed 100
ethtool -s eth0 duplex full

Actual Results:  Link stays in 100MBit Half Duplex mode

Expected Results:  Link changes to 100MBit Full Duplex mode

Additional info:

Workaround: Boot with a custom kernel. With a self-built kernel.org
kernel, ethtool works as expected. The RedHat Linux 9 kernels also work.
Comment 1 Suzanne Hillman 2004-02-04 13:08:39 EST

*** This bug has been marked as a duplicate of 108115 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.