Bug 113987 - xscreensaver dies randomly
xscreensaver dies randomly
Status: CLOSED DUPLICATE of bug 126428
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 17:45 EST by rob
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xscreensaver log/debug output (1.85 KB, application/x-gzip)
2004-01-20 17:48 EST, rob
no flags Details
xscreensaver core dump (256.31 KB, application/x-gzip)
2004-01-20 17:50 EST, rob
no flags Details

  None (edit)
Description rob 2004-01-20 17:45:29 EST
Description of problem:

xscreensaver dies randomly with both blank and gflux (and probably
other) screen savers.

Version-Release number of selected component (if applicable):

xscreensaver-4.14-2

How reproducible:

reproducible every other day with gflux as screensaver.
reproducible every 2 weeks with blank as screensaver.

Steps to Reproduce:
1.  Configure xscreensaver.  Make it require a password to unlock.
2.  Walk away for a while.
3.  Come back and see if the screensaver is running.
  
Actual results:
sometimes the screensaver is not running.

Expected results:

the screensaver should not die and should require a password to unlock
 if locking is enabled.

Additional info:
 
                                                                     
                                                                     
                 some gdb output:
<snip>
Core was generated by `xscreensaver -sync -verbose -no-capture -nosplash'.
Program terminated with signal 11, Segmentation fault.
<snip>
(gdb) bt
#0  0x007bcc32 in ?? ()
#1  0x007fbd26 in ?? ()
#2  0x080508b0 in restore_real_vroot_handler (sig=11) at windows.c:635
#3  0x007fba38 in ?? ()
#4  0x0000000b in ?? ()
#5  0x00000033 in ?? ()
Comment 1 rob 2004-01-20 17:48:09 EST
Created attachment 97139 [details]
xscreensaver log/debug output

with gflux as the screensaver.
Comment 2 rob 2004-01-20 17:50:37 EST
Created attachment 97140 [details]
xscreensaver core dump

dumped with gflux as screensaver.
Comment 3 Alan McKay 2004-08-03 20:33:56 EDT
I'm running Fedora Tettnang release as downloaded 2 weeks ago, and
this problem still seems to be there except it comes up more randomly.
 And given that I run the machine 24x7 and have only seen the problem
when the saver kicks in, I have to assume that it only locks up the
machine if you try to use the machine while the particular SS is
active.  i.e. if you let the problem SS run it's course (e.g. while
I'm gone all day) and let the next one start, it's fine.  Maybe that's
an invalid assumption.

I've had it happen twice now.  Sorry, don't recall which saver it was
either time.  First time when I moved the mouse to deactive the saver
text appeared in the top left of the screen.  i.e. it was console text
coming out over top of the X server as though X were not even running
if you get what I mean.  I could still move the mouse and alt-tab
windows - for a bit.  Then things locked up completely.  But when I
hit the power button X came down and then I had the regular clean
Linux shutdown with all the "blah blah blah ..... [OK]"

The second time was just a few minutes ago and there was no console
text coming through, and it was hung tight from the beginning and the
power button seemed to initiate a shutdown but I didn't get all the
"blah blah blah ..... [OK]" - a few lines of shutdown text came up
then the power went out.  On reboot filesystems were clean though.

I've got an Nvidea Gforce (440 I think) video card, and an ASUS mobo
either  A7N8X-X or A7V8X-X don't recall of the top of my head.  

I will disable OpenGL savers to see if that fixes it.  Are they all
the ones that start with "GL"?  

BTW, sorry but I entered the above text into another bug but this one
seems to be a much better fit.
Comment 4 rob 2004-08-04 09:26:34 EDT
do you run ldaps or any other unusual authentication methods?

i think the problems i was seeing are better described here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121734
Comment 5 Alan McKay 2004-08-04 09:53:16 EDT
Nope.  I just have /etc/passwd.  I only log in via SSH (no telnet) but
I don't think that should matter.  In any case I've turned off all the
GL savers and we'll see what happens.
Comment 6 Ray Strode [halfline] 2004-08-04 10:10:45 EDT
Hi Alan,
This appears to be a duplicate of bug 126428.  Let's track the problem
there.

*** This bug has been marked as a duplicate of 126428 ***
Comment 7 Alan McKay 2004-08-04 10:14:33 EDT
No, that's not at all what is happening to me.  As noted, I leave my
machine on 24x7 and I have never had a problem with it after being
idle for hours on end.  I get up in the morning and it's been sitting
there 7 or 8 hours and no problems.  Get home from work and same
thing.  I don't think this is a duplicate.

Actually, probably my bad.  Reading the original report in this bug
report, the two are probably duplicates but my problem is something
else  altogether so I probably should have started a new bug.  But if
you feel my problem is closely enough related I supposed we could
track them together.
Comment 8 Ray Strode [halfline] 2004-08-04 10:22:36 EDT
Yes, I'm sorry.  I actually meant to address that message to Rob. 
Your problem sounds like it may be an X problem.  Did disabling the
OpenGL screensavers help you?  Either way, could you post a new bug to
the xorg component?  Thanks.
Comment 9 rob 2004-08-04 10:53:59 EDT
just to clarify my situation-

i desire a screensaver that locks my screen.

after having problems with the opengl screensavers dying randomly, i
switched to a blank screensaver.  this successfully avoided bugs seen
in #113987 and #126428.  however, another bug appeared when unlocking
the screen, #121734.  i believe a similar problem causes gdm to crash
when ldaps is configured for authentication.

do you still think i should post a new bug to xorg?  if not xorg, what
is an appropriate component to post #121734 to?

thanks for your help.

Comment 10 Ray Strode [halfline] 2004-08-04 11:17:15 EDT
Hi Rob,

Comment 6 was supposed to be addressed to you, but comment 8 was
addressed to Alan.  

You shouldn't need to do anything else right now, until more activity
occurs on the relevent open bugs.
Comment 11 Alan McKay 2004-08-09 08:02:09 EDT
Well, I've been running ever since with all the GLxzy screen savers
disabled, and have not had the problem again.  It seems pretty clear
that's what it was since I used to get the hang once a day prior to that.
Comment 12 Red Hat Bugzilla 2006-02-21 14:00:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.