Bug 1139894 - RHSCL is packaged in ISO but cannot be used via install_packages
Summary: RHSCL is packaged in ISO but cannot be used via install_packages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
urgent
high vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1139893 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-09-09 22:40 UTC by Corey Welton
Modified: 2019-09-25 20:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Note: ISO install users should assure their target sat6 system has access to the RHSCL library, via Red Hat's CDN or other methods (i.e., an existing Satellite 5 content source)
Clone Of:
Environment:
Last Closed: 2014-09-24 15:07:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1127189 None None None 2019-06-20 05:12:38 UTC
Red Hat Knowledge Base (Solution) 1120693 None None None Never
Red Hat Knowledge Base (Solution) 1194163 None None None Never

Internal Links: 1127189

Description Corey Welton 2014-09-09 22:40:28 UTC
Description of problem:

The ISO contains RHSCL/* packages, but that directory/set of RPMs is never set up anywhere in the install_packages, so user is never given access to that repo. Ergo, install will fail on deps issues.

Partial workaround is to use one of:

yum-config-manager --enable rhel-server-rhscl-7-rpms
yum-config-manager --enable rhel-server-rhscl-6-rpms

As appropriate for user's platform.


Docs note should be something like:

Note: ISO install users should assure their target sat6 system has access to the RHSCL library, via Red Hat's CDN or other methods (i.e., an existing Satellite 5 content source)

Comment 2 Corey Welton 2014-09-09 22:49:28 UTC
*** Bug 1139893 has been marked as a duplicate of this bug. ***

Comment 7 Partha Aji 2014-09-15 21:11:58 UTC
Created redmine issue http://projects.theforeman.org/issues/7445 from this bug

Comment 8 Mike McCune 2014-09-15 21:13:48 UTC
PR:

https://github.com/Katello/katello-misc/pull/42

Comment 11 Corey Welton 2014-09-23 18:05:27 UTC
Verified against ISO for Satellite-6.0.4-RHEL-7-20140923.0-Satellite-x86_64 and Satellite-6.0.4-RHEL-6-20140923.0-Satellite-x86_64

Comment 12 Bryan Kearney 2014-09-24 15:07:49 UTC
The ISO has been updated, and can be downloaded from

https://access.redhat.com/downloads/content/250/ver=6.0/rhel---7/6.0/x86_64/product-downloads


Note You need to log in before you can comment on or make changes to this bug.