Bug 113996 - unbound keys for jp kbd in console
Summary: unbound keys for jp kbd in console
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-21 02:56 UTC by Jens Petersen
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-06 09:45:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2004-01-21 02:56:29 UTC
Description of problem:
The 'ï¿¥'-'|' key to the left of Backspace and the '\'-'_'
key to the left of Right_Shift key don't seem to be bound
currently in the console.  Not being able to input these
characters easily on a console is highly annoying.

Version-Release number of selected component (if applicable):
kernel-2.6.1-1.47

How reproducible:
every time

Steps to Reproduce:
1. Set the keyboard to jp106 during (after) install.
2. Press the Yen key (left of Backspace) in a VC.
3. Press the Backslash key (left of the right Shift key) in a VC.
  
Actual results:
No output on console.

Expected results:
\\

Additional info:
The Yen key usually outputs Backslash (or vice versa
depending on the font etc).  They work fine in FC1.

Comment 1 Jens Petersen 2004-01-29 02:28:50 UTC
Seems to be ok now with kernel-2.6.1-1.61.

Comment 2 Jens Petersen 2004-02-13 23:21:36 UTC
The problem is happening with kernel-2.6.1-1.138.2.1 now too.

Comment 3 Bill Nottingham 2004-07-29 21:25:38 UTC
Is this any better recently?

Comment 4 Eido Inoue 2004-07-29 21:30:44 UTC
I have a jp106 on fc2 and I have no problems pressing the yen key (to
get the backslash)

Comment 5 Eido Inoue 2004-07-29 21:31:37 UTC
comment 4: using kernel-2.6.6-1.435.2.3

Comment 6 Jens Petersen 2004-08-06 09:45:57 UTC
Yes, looks fine to me with RHEL4-re0806.nightly
(kernel-2.6.7-1.505) too. :)

Probably already fixed in A4 I suspect but I haven't test that.


Note You need to log in before you can comment on or make changes to this bug.