Bug 1139997 - rebalance is not resulting in the hash layout changes being available to nfs client
Summary: rebalance is not resulting in the hash layout changes being available to nfs ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.4.5
Hardware: Unspecified
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1120456 1125824 1140338
Blocks: glusterfs-3.4.6 1125958 1138393
TreeView+ depends on / blocked
 
Reported: 2014-09-10 07:06 UTC by Raghavendra G
Modified: 2015-05-15 17:03 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1125824
Environment:
Last Closed: 2015-04-13 07:09:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-09-10 08:38:17 UTC
REVIEW: http://review.gluster.org/8678 (cluster/dht: Fix dht_access treating directory like files) posted (#1) for review on release-3.4 by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Anand Avati 2014-10-09 05:40:19 UTC
REVIEW: http://review.gluster.org/8678 (cluster/dht: Fix dht_access treating directory like files) posted (#2) for review on release-3.4 by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Anand Avati 2014-10-09 07:34:43 UTC
REVIEW: http://review.gluster.org/8678 (cluster/dht: Fix dht_access treating directory like files) posted (#3) for review on release-3.4 by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Anand Avati 2014-10-20 14:55:03 UTC
COMMIT: http://review.gluster.org/8678 committed in release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 7a1e42e0d4be42fa8aa0c7a430b4fbc3ab509705
Author: Shyam <srangana@redhat.com>
Date:   Tue Aug 12 10:48:27 2014 -0400

    cluster/dht: Fix dht_access treating directory like files
    
    When the cluster topology changes due to add-brick, all sub
    volumes of DHT will not contain the directories till a rebalance
    is completed. Till the rebalance is run, if a caller bypasses
    lookup and calls access due to saved/cached inode information
    (like NFS server does) then, dht_access misreads the error
    (ESTALE/ENOENT) from the new subvolumes and incorrectly tries
    to handle the inode as a file. This results in the directories
    in memory state in DHT to be corrupted and not heal even post
    a rebalance.
    
    This commit fixes the problem in dht_access thereby preventing
    DHT from misrepresenting a directory as a file in the case
    presented above.
    
    Change-Id: Idcdaa3837db71c8fe0a40ec0084a6c3dbe27e772
    BUG: 1139997
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-on: http://review.gluster.org/8462
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/8678
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.