Bug 1140015 - Munin mysql plugin fails to parse MariaDB status
Summary: Munin mysql plugin fails to parse MariaDB status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: munin
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: d. johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-10 07:34 UTC by Juan Orti Alcaine
Modified: 2015-04-21 18:54 UTC (History)
5 users (show)

Fixed In Version: munin-2.0.25-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-06 03:11:46 UTC


Attachments (Terms of Use)

Description Juan Orti Alcaine 2014-09-10 07:34:16 UTC
Description of problem:
When monitoring MariaDB, the plugin fails with errors like:
Error output from mysql_innodb_io:
    Unknown section: Main thread process no. 1255, id 140088714413824, state: flushing log at /etc/munin/plugins/mysql_innodb_io line 1098.
Service 'mysql_innodb_io' exited with status 255/0.

Version-Release number of selected component (if applicable):
munin-2.0.21-1.fc20.noarch
munin-node-2.0.21-1.fc20.noarch
munin-common-2.0.21-1.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create the links in /etc/munin/plugins:

lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_bin_relay_log -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_commands -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_connections -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_files_tables -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_innodb_bpool -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_innodb_bpool_act -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:32 mysql_innodb_insert_buf -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_innodb_io -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_innodb_io_pend -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_innodb_log -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_innodb_rows -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_innodb_semaphores -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_innodb_tnx -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_myisam_indexes -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:33 mysql_network_traffic -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_qcache -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_qcache_mem -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_select_types -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_slow -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_sorts -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_table_locks -> /usr/share/munin/plugins/mysql_
lrwxrwxrwx. 1 root root   31 sep  1 15:34 mysql_tmp_tables -> /usr/share/munin/plugins/mysql_

2. Configure the plugin in /etc/munin/plugin-conf.d/mysql:
[mysql_*]
  env.mysqlconnection DBI:mysql:mysql
  env.mysqluser munin
  env.mysqlpassword mypassword

3. Create the database user:
grant process, show databases, super on *.* to munin@localhost identified by 'mypassword';
grant select on mysql.* to munin@localhost;
grant select on performance_schema.* to munin@localhost;
flush privileges;

4. Run one check
munin-run mysql_innodb_io

Actual results:
Error output from mysql_innodb_io:
    Unknown section: Main thread process no. 1255, id 140088714413824, state: flushing log at /etc/munin/plugins/mysql_innodb_io line 1098.
Service 'mysql_innodb_io' exited with status 255/0.

Expected results:
ib_io_read.value 2805
ib_io_write.value 278172
ib_io_log.value 144555
ib_io_fsync.value 148529

Additional info:
This patch fixes the problem for me
https://github.com/kjellm/munin-mysql/commit/77c3f88f4807fb07d0ce6c26ef86d0c7eb196f8b?diff=unified

Comment 1 Mehmet Avcioglu 2014-09-18 20:51:40 UTC
I confirm that the mentioned patch fixes this issue.

Comment 3 Matthias Runge 2015-02-24 09:36:11 UTC
Any progress here? This bug is true for epel7 as well

Comment 4 d. johnson 2015-02-24 15:04:00 UTC
This should already be fixed in munin-2.0.25-1.fc20.noarch / el7.

Please update and verify.

Comment 5 Matthias Runge 2015-02-24 15:06:10 UTC
It's not fixed in munin-2.0.25-1.el7.noarch

I applied that patch manually afterwards, and my local patched version works for me.

Comment 6 Fedora Update System 2015-03-07 05:58:15 UTC
munin-2.0.25-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.25-2.el5

Comment 7 Fedora Update System 2015-03-07 05:59:53 UTC
munin-2.0.25-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.25-2.el6

Comment 8 Fedora Update System 2015-03-07 06:00:25 UTC
munin-2.0.25-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/munin-2.0.25-2.el7

Comment 9 Fedora Update System 2015-03-07 06:00:48 UTC
munin-2.0.25-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/munin-2.0.25-2.fc20

Comment 10 Fedora Update System 2015-03-07 06:01:11 UTC
munin-2.0.25-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/munin-2.0.25-2.fc21

Comment 11 Fedora Update System 2015-03-07 06:01:37 UTC
munin-2.0.25-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/munin-2.0.25-2.fc22

Comment 12 Fedora Update System 2015-03-08 22:38:42 UTC
Package munin-2.0.25-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing munin-2.0.25-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1031/munin-2.0.25-2.el6
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2015-04-06 03:11:46 UTC
munin-2.0.25-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-04-06 03:12:18 UTC
munin-2.0.25-2.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-04-06 03:12:53 UTC
munin-2.0.25-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-04-06 08:34:16 UTC
munin-2.0.25-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-04-06 08:36:08 UTC
munin-2.0.25-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-04-21 18:54:11 UTC
munin-2.0.25-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.