Bug 1140034 - Prompt info is not exact for command "virsh desc" with option --title
Summary: Prompt info is not exact for command "virsh desc" with option --title
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-10 08:28 UTC by zhengqin
Modified: 2015-11-19 05:52 UTC (History)
7 users (show)

Fixed In Version: libvirt-1.2.13-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:52:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description zhengqin 2014-09-10 08:28:06 UTC
From manual of virsh:

 desc domain [[--live] [--config] | [--current]] [--title] [--edit]
       [--new-desc New description or title message]
           Show or modify description and title of a domain.

Flag --title selects operation on the title field instead of description.



Version-Release number of selected component (if applicable):
libvirt-1.2.8-1.el7.x86_64


Steps to Reproduce:
1. Here is help usage for command "virsh desc" with option --title:

# virsh desc --help
   NAME
     desc - show or set domain's description or title

   SYNOPSIS
     desc <domain> [--live] [--config] [--current] [--title] [--edit] 
[[--new-desc] <string>]...

   DESCRIPTION
     Allows to show or modify description or title of a domain.

   OPTIONS
     [--domain] <string>  domain name, id or uuid
     --live             modify/get running state
     --config        modify/get persistent configuration
     --current      modify/get current state configuration
     --title            modify/get the title instead of description



2. Issue following commands:

[root@rhel7-b1 ~]# virsh desc rhel7 --title
No description for domain: rhel7

[root@rhel7-b1 ~]# virsh desc rhel7 --title t1
Domain description updated successfully


Actual results:
1. The prompt info point out "No description for domain: rhel7" and 
"Domain description updated successfully"


Expected results:
1. The prompt info should be improved to "No title for domain: rhel7" and 
"Domain title updated successfully" according to its usage: "--title modify/get the title instead of description"

Comment 1 zhengqin 2014-09-10 08:37:35 UTC
Here are about description info which should be different from title:

# virsh desc rhel7_Test
No description for domain: rhel7_Test

# virsh desc rhel7_Test desc1
Domain description updated successfully

# virsh desc rhel7_Test --title
No description for domain: rhel7_Test

# virsh desc rhel7_Test --title t1
Domain description updated successfully

# virsh desc rhel7_Test --title 
t1

Comment 2 Peter Krempa 2014-09-10 12:46:09 UTC
Fixed upstream:

commit 78948e1c808d67648680be8c4814631abbf20d88
Author: Peter Krempa <pkrempa@redhat.com>
Date:   Wed Sep 10 10:46:41 2014 +0200

    virsh: desc command in --title mode mentions description instead of title
    
    Tweak the messages so that they mention "title" rather than
    "description" when operating in title mode. Also fixes one missing "%s"
    before non-formatted gettext message.
    
    Before:
     $ virsh desc --title dom
     No description for domain: dom
    
    After:
     $ virsh desc --title dom
     No title for domain: dom

v1.2.8-76-g78948e1

Comment 6 Luyao Huang 2015-05-28 07:24:32 UTC
I can reproduce this issue with libvirt-1.2.8-16.el7.x86_64:

# virsh desc test3 --title
No description for domain: test3

# virsh desc test3 --title --edit
Domain description updated successfully

# virsh desc test3 --title --edit
Domain description not changed.

# virsh desc test3 --title 123
Domain description updated successfully

And verify this bug with libvirt-1.2.15-2.el7.x86_64:

# virsh desc test3 --title
No title for domain: test3

# virsh desc test3 --title --edit
Domain title updated successfully

# virsh desc test3 --title --edit
Domain title not changed

# virsh desc test3 --title sssss
Domain title updated successfully

Comment 8 errata-xmlrpc 2015-11-19 05:52:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.