Bug 11401 - error recovery
Summary: error recovery
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-13 21:26 UTC by Christopher Abbey
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-15 19:37:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Abbey 2000-05-13 21:26:29 UTC
There needs to be some form of error recovery in the installer, I've had
three installs in a row crash durring post install config. The only way
I've found out of that case is to kill off the installer and reboot the
machine. Some of these are truely fatal (i.e. sending the dhcp request
out the wrong eth iface) but others aren't (i.e. mounting an auxilary
partition that's not part of the install, but was specified in the config,
and it can't be mounted because it's busy (in actuality mounted by hand
from the bash console to find the network config to avoid the dhcp issue
above)). These non-fatal errors should allow a retry or skip kind of
option; while the truely fatal errors should at least provide a gracefull
reboot solution in the gui (for the newbies).

Comment 1 Michael Fulbright 2000-06-09 22:21:10 UTC
Adding better error handling is a continual process for the anaconda team.

Comment 2 Michael Fulbright 2000-09-15 19:37:34 UTC
Please submit individual bug reports for specific problems so we can better
address them.


Note You need to log in before you can comment on or make changes to this bug.