Bug 114023 - g++-ssa cannot find include files
g++-ssa cannot find include files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Diego Novillo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 10:22 EST by William Cohen
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-30 10:30:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Program that includes <string> to demonstrate the problem (127 bytes, text/plain)
2004-01-21 10:24 EST, William Cohen
no flags Details

  None (edit)
Description William Cohen 2004-01-21 10:22:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Have simple program attached that does not compile with g++-ssa, it
compiles fine with the existing g++ compiler. The problem is that the
g++-ssa compiler cannot find the include files.

Version-Release number of selected component (if applicable):
gcc-c++-ssa-3.5ssa-0.20040120.109

How reproducible:
Always

Steps to Reproduce:
1. Install the rawhide g++-ssa and related rpms from the build system
2. compile attached program with "g++ inc.cpp" (verify this works)
3. compile attached program with "g++-ssa inc.cpp"
    

Actual Results:  $ g++-ssa inc.cpp
inc.cpp:3:18: string: No such file or directory


Expected Results:  Find include file and build without problem.

Additional info:
Comment 1 William Cohen 2004-01-21 10:24:29 EST
Created attachment 97146 [details]
Program that includes <string> to demonstrate the problem
Comment 2 William Cohen 2004-01-21 10:31:40 EST
This appears to be a problem with the gcc-ssa rpms built in the build
system. The rpms at
http://people.redhat.com/dnovillo/pub/tree-ssa/snapshot/RPMS/
do not have this problem
Comment 3 William Cohen 2004-01-21 11:48:16 EST
The gcc-c++-ssa-3.5ssa-0.20040119.snapshot
at http://people.redhat.com/dnovillo/pub/tree-ssa/snapshot/RPMS/

exhibit the same problem.



 /usr/bin/g++-ssa -v inc.cpp
Reading specs from /lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --libdir=/lib/ssa --libexecdir=/lib/ssa
--host=i686-redhat-linux --enable-shared --enable-threads=posix
--disable-checking --enable-languages=c,c++,java,objc,f95
--with-system-zlib --enable-__cxa_atexit --disable-multilib
Thread model: posix
gcc version 3.5-tree-ssa 20040119 (Fedora Core Rawhide 3.5ssa-snapshot)
 /lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/cc1plus -quiet -v
-D_GNU_SOURCE inc.cpp -quiet -dumpbase inc.cpp -mtune=pentiumpro
-auxbase inc -version -o /tmp/ccjccPIh.s
ignoring nonexistent directory
"/lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/../../../../include/c++/3.5-tree-ssa"
ignoring nonexistent directory
"/lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/../../../../include/c++/3.5-tree-ssa/i686-redhat-linux"
ignoring nonexistent directory
"/lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/../../../../include/c++/3.5-tree-ssa/backward"
ignoring nonexistent directory
"/lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/../../../../i686-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /lib/ssa/gcc/i686-redhat-linux/3.5-tree-ssa/include
 /usr/include
End of search list.
GNU C++ version 3.5-tree-ssa 20040119 (Fedora Core Rawhide
3.5ssa-snapshot) (i686-redhat-linux)
        compiled by GNU C version 3.2.3 20030502 (Red Hat Linux 3.2.3-20).
GGC heuristics: --param ggc-min-expand=64 --param ggc-min-heapsize=64317
inc.cpp:3:18: string: No such file or directory

It looks like the system gcc is searching in:

ignoring nonexistent directory "/usr/i386-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/include/c++/3.3.2
 /usr/include/c++/3.3.2/i386-redhat-linux
 /usr/include/c++/3.3.2/backward
 /usr/local/include
 /usr/lib/gcc-lib/i386-redhat-linux/3.3.2/include
 /usr/include
End of search list.


Note You need to log in before you can comment on or make changes to this bug.