Bug 1140256 - system-profile-transition rpm should avoid using advanced rpmlib capabilities
Summary: system-profile-transition rpm should avoid using advanced rpmlib capabilities
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Transitions
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Lukas Pramuk
QA Contact: Grant Gainey
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-10 15:14 UTC by Lukas Pramuk
Modified: 2019-09-25 21:05 UTC (History)
7 users (show)

Fixed In Version: rubygem-hammer_cli_import-0.10.5-1
Doc Type: Bug Fix
Doc Text:
The system-profile-transition rpm has been changed to avoid using advanced rpmlib capabilities to avoid issues with the transition tool and for times when the build operating system is greater than the OS being installed.
Clone Of:
Environment:
Last Closed: 2014-11-13 22:29:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1857 0 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2014-11-14 03:28:23 UTC

Description Lukas Pramuk 2014-09-10 15:14:26 UTC
Description of problem:
system-profile-transition rpm should avoid using advanced rpmlib capabilities. hammer import content-host command shows build instruction how to create on Sat6 an rpm for systems transition. Built rpm "system-profile-transition-*.rpm" requires some advanced rpmlib capabilities!
Just imagine situation Sat6 is on RHEL6 machine, therefore built rpm will require rpmlib capabilities like FileDigests, PayloadIsXz, according to building OS. These capabilities cannot be handled on RHEL5. And the rpm is going to be installed on Sat5 machine, which can have various OSes. The problem can arise if build_OS > install_OS.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_import-0.10.4-1.1.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. @sat6 obtain wrong build instruction:
# hammer import content-host --csv-file=/tmp/export/system-profiles.csv --export-directory=/root/content-hosts

2. @sat6 build the rpm:
# rpmbuild -ba --define "_topdir /root/content-hosts" /root/content-hosts/SPECS/system-profile-transition-*.spec

3. @sat5 built rpm requires advanced rpmlib capabilities:
# rpm -ivh /root/system-profile-transition-<fqdn>-1409658421-0.0.1-1.noarch.rpm
error: Failed dependencies:
	rpmlib(FileDigests) <= 4.6.0-1 is needed by system-profile-transition-<fqdn>-1410316694-0.0.1-1.noarch
	rpmlib(PayloadIsXz) <= 5.2-1 is needed by system-profile-transition-<fqdn>-1410316694-0.0.1-1.noarch


Actual results:
the rpm built on rhel6/7 cannot be installed on rhel5

Expected results:
the rpm built on rhel6/7 can be installed on rhel5

Comment 1 RHEL Program Management 2014-09-10 15:23:07 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tomas Lestach 2014-09-11 10:06:14 UTC
Right, we need to add more defines to the rpmbuild, see
https://access.redhat.com/solutions/41415
https://bugzilla.redhat.com/show_bug.cgi?id=615390
for more info.

Comment 4 Lukas Pramuk 2014-09-25 14:25:39 UTC
We need to add these:

%define _binary_filedigest 1
%define _binary_payload w9.gzdio

Comment 5 Grant Gainey 2014-10-01 18:11:44 UTC
Note: The implication of this bug is that customers running Sat5 on RHEL5 will not be able to use the sat5to6 transition tool.

Comment 7 Grant Gainey 2014-10-09 14:50:03 UTC
upstream commit 8cb9d13800ac83916d244425972c8b2a633ed691

Comment 12 errata-xmlrpc 2014-11-13 22:29:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2014:1857


Note You need to log in before you can comment on or make changes to this bug.