Bug 1140286 - Improve master lock election process in the InfinispanIndexManager
Summary: Improve master lock election process in the InfinispanIndexManager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR1
: 6.3.1
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-10 15:52 UTC by Gustavo Fernandes
Modified: 2015-01-26 14:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-26 14:03:16 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-4711 Major Resolved Remoted commands to a dead master node can be re-forwarded to a valid backend 2014-09-10 15:52:28 UTC
JBoss Issue Tracker ISPN-4712 Major Resolved Mutable SearchFactory needs to be passed new types exclusively 2014-09-10 15:52:54 UTC
JBoss Issue Tracker ISPN-4713 Major Resolved Reject incoming Query RPCs on stopped and being-shutdown caches 2014-09-10 15:53:08 UTC
JBoss Issue Tracker ISPN-4714 Minor Resolved Improve logging to trace IndexManager's lock promotion phases 2014-09-10 15:53:30 UTC
JBoss Issue Tracker ISPN-4715 Major Resolved Resolve race condition in Lock promotion of IndexManager 2014-09-10 15:53:50 UTC

Description Gustavo Fernandes 2014-09-10 15:52:28 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Gustavo Fernandes 2014-09-10 17:47:51 UTC
PR for 6.3.x: https://github.com/infinispan/jdg/pull/242

Comment 3 Gustavo Fernandes 2014-09-10 18:09:27 UTC
PR for 6.4.x: https://github.com/infinispan/jdg/pull/243

Comment 4 Radim Vansa 2014-09-11 17:10:49 UTC
Master lock election process seems to be working in my tests with 6.3.1.CR1


Note You need to log in before you can comment on or make changes to this bug.