Bug 1140293 - Uninformative status while data is not recieved by optimizer
Summary: Uninformative status while data is not recieved by optimizer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-optimizer
Version: 3.5.0
Hardware: All
OS: All
low
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Sivák
QA Contact: Shira Maximov
URL:
Whiteboard:
: 1156122 (view as bug list)
Depends On:
Blocks: 1232536
TreeView+ depends on / blocked
 
Reported: 2014-09-10 16:05 UTC by Lukas Svaty
Modified: 2016-03-09 20:21 UTC (History)
4 users (show)

Fixed In Version: ovirt-optimizer-0.9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:21:25 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0427 0 normal SHIPPED_LIVE ovirt-optimizer bug fix and enhancement update 2016-03-10 01:19:39 UTC
oVirt gerrit 41290 0 master MERGED Change the error message when the UI plugin can't retrieve the results Never
oVirt gerrit 41292 0 master MERGED Change the error message when verification fails Never

Description Lukas Svaty 2014-09-10 16:05:23 UTC
Description of problem:
When jboss-as with ovirt-optimizer is listening on incorrect address ui-plugin of optimizer shows "Status: Data refresh failed: 0".
This status may come up any time optimizer is not accepting packets from ui-plugin machine. 
First I though that 0 is a counter of how many refresh interval ui-plugin failed to load data. Unfortunately it's just a simple zero :(


Version-Release number of selected component (if applicable):
vt2.2

How reproducible:
100%

Steps to Reproduce:
1. Start ovirt-optimizer in jboss
2. Start ovirt-optimizer-ui-plugin on engine
3. Configure jboss to listen only on localhost
4. See the status

Actual results:
Status: Data refresh failed: 0

Expected results:
At least delete the ": 0". From the end. I would prefer to give admin some kind of informative message. "Failed to send data to ovirt-optimizer" or something similiar.

Additional info:
Just a cosmetic change I don't think it needs any logs. If necessary I'll add them.

Comment 1 Martin Sivák 2014-09-11 07:22:17 UTC
It it the HTTP status that was returned with the failed call. 0 means there was no connection. If you configure the ui plugin to talk to some arbitrary web server, you will get others.. 404 for not found, 403 for prohibited

Comment 2 Doron Fediuck 2014-10-02 11:53:41 UTC
(In reply to Martin Sivák from comment #1)
> It it the HTTP status that was returned with the failed call. 0 means there
> was no connection. If you configure the ui plugin to talk to some arbitrary
> web server, you will get others.. 404 for not found, 403 for prohibited

Worth adding a status indication (all good / cannot connect to server)?

Comment 3 Doron Fediuck 2014-10-26 15:29:46 UTC
*** Bug 1156122 has been marked as a duplicate of this bug. ***

Comment 7 Shira Maximov 2015-10-11 15:50:04 UTC
verified on :  Red Hat Enterprise Virtualization Manager Version: 3.6.0-0.18.el6

Comment 8 Julie 2016-02-22 04:14:32 UTC
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

Cause:
Consequence:
Fix:
Result:

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 10 errata-xmlrpc 2016-03-09 20:21:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0427.html


Note You need to log in before you can comment on or make changes to this bug.