Bug 114042 - Does not work due to korean module
Does not work due to korean module
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 14:42 EST by Stephen John Smoogen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-22 18:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2004-01-21 14:42:21 EST
Description of problem:

mailman-2.1.4-1 in devel does not work due to the lack of a korean
module. The work-around is to comment out the 'import korean' listings
in the various paths.py. Do not have patch as this is my first time
working with this tool.
Comment 1 Kaj J. Niemi 2004-01-21 15:30:28 EST
What version of python are you running? It seems to work out of the
box on both of my mailman servers.

% rpm -q python mailman
python-2.2.3-7
mailman-2.1.4-1

AFAIK the korean module comes with mailman
(/var/mailman/pythonlib/orean) so the real problem might be something
beneath.

Comment 2 Stephen John Smoogen 2004-01-21 15:56:49 EST
Hmm ok this may be my own fault. Sigh. I am running it on 3WS-U1
(thought it was the fedora box) with

[root@kosh mailman-2.1.4]# rpm -q python
python-2.2.3-5

So I am guessing it is something I missed.
Comment 3 John Dennis 2004-01-21 16:36:29 EST
No, it may not be something you missed but something I missed. A quick
romp through the mailman archives shows a lot of dicussions concerning
the chinese/japanese/korean codecs just prior to the 2.1.4 release and
last minute fixes. I still have not gotten to the bottom of it, but
I'm looking.
Comment 4 John Dennis 2004-01-21 17:04:00 EST
O.K. here's the deal as far as I can tell. The korean and japanese
codecs are not part of the python package, they are built and
installed with mailman and should have been installed in 
/var/mailman/pythonlib with the korean moduel being in
/var/mailman/pythonlib/korean.

I just did a rpm -qlp on mailman-2.1.4-1.i386.rpm and the
/var/mailman/pythonlib/korean files are there. Please verify on your
system they are present. You might also want to verify with "rpm -ql
mailman | grep korean" you see the files listed, they should be.

Also, by any chance did you change anything in your configuration
related to paths or installation directories?
Comment 5 Stephen John Smoogen 2004-01-22 12:39:41 EST
rpm -qlp mailman-2.1.4-1.i386.rpm | grep -i korean
<4099 smooge@kosh->i386> 

I didnt make any changes to the src.rpm.. just did a download of
.src.rpm, rpmbuild -ba, and then an install. I will redo and grep for
any errors that would be helpful
Comment 6 Stephen John Smoogen 2004-01-22 13:10:33 EST
Ok the problem looks to be something with Enterprise Linux.. and so
not a bug :)

for p in email-2.5.4 JapaneseCodecs-1.4.10 KoreanCodecs-2.0.5; \
do \
    gunzip -c ./$p.tar.gz | (cd . ; tar xf -); \
    (cd ./$p ; umask 02 ;
PYTHONPATH=/var/tmp/mailman-root/var/mailman/pythonlib /usr/bin/python
setup.py --quiet install --install-lib /var
/tmp/mailman-root/var/mailman/pythonlib --install-purelib
/var/tmp/mailman-root/var/mailman/pythonlib --install-data
/var/tmp/mailman-root/v
ar/mailman/pythonlib); \
done
<command line>:1:15: missing terminating " character
<command line>:1:18: missing terminating " character
<command line>:1:18: missing terminating " character
<command line>:1:17: missing terminating " character
<command line>:1:20: missing terminating " character
error: command 'gcc' failed with exit status 1
<command line>:1:15: missing terminating " character
<command line>:1:18: missing terminating " character
<command line>:1:18: missing terminating " character
<command line>:1:17: missing terminating " character
<command line>:1:20: missing terminating " character
error: command 'gcc' failed with exit status 1
make[1]: *** [install-packages] Error 1

That seems to be the only error in the item and the email and Japanese
codecs are installed.. so I am guessing it is something in the Korean
that Enterprise doesnt like.
Comment 7 John Dennis 2004-01-22 13:19:17 EST
Hmm... the mailman-2.1.4-1.i386.rpm which is in Fedora Core 2
definitely has the korean module in it. Any reason you're not using
the binary rpm's? In general we don't like to support rpm's that don't
originate from our build system. 

Do take a look and see if you've got build errors, perhaps there is a
missing build prereq in the spec file that needs fixing.

During the build you should see the following tar file getting
unpacked and installed:

mailman-2.1.4/misc/KoreanCodecs-2.0.5.tar.gz

Do you?
Comment 8 John Dennis 2004-01-22 18:52:16 EST
I have built this twice, once on a fresh install of RHEL3 and again
after applying all the RHEL3 updates. There were no build problems,
the korean module was built and packaged each time. I cannot explain
the problem you are seeing. I don't think this is a bug with the
mailman 2.1.4 package.
Comment 9 Stephen John Smoogen 2004-01-23 13:06:21 EST
Ok I have now replicated the problem and also replicated the good fix.
The difference seems to be building as root or as a user.

Build as root, everything is fine.
Build as a user, KoreanModules fails over and over again             
                                                       replicated on 3
different RHEL environments now.                                     
                                                                
                                                                     
                                                                      
%XXX            %(rpm -q redhat-release)                             
                                                                      
%_topdir        /home/smooge/RPM_DEVEL/%{XXX}                        
                                                                      
%debug_package  %{nil}                                               
                                                                      
%distribution   Smoogen Linux                                        
                                                                      
%packager       "Stephen J Smoogen <smooge@mindspring.com>"          
                                                                      
%vendor         "Stephen J Smoogen <smooge@mindspring.com>"          
                                                                      
                                                                     
                                                                     
                                                                     
                                                                      
This is my .rpmmacros                                                
                                                                      
                                                                     
                                                                      
CFLAGS=-W -Wall -Wfloat-equal -Wundef -Wshadow -Wpointer-arith       
                                                                      
-Wmissing-format-attribute -g -ggdb                                  
                                                                      
                                                                     
                                                                      
these are my default cflags.                                         
                                                                      
                                                                     
                                                                      
                                                                     
                                                                      
No idea what is causing this... weird. Definately NOTABUG, but thought
I would add the solution                                             
                                                                        
Comment 10 Stephen John Smoogen 2004-01-23 14:13:12 EST
Tracked it down. It is due to the -g flag in my CFLAGS. Remove it and
-ggdb and everything works fine. Have it in there and mailman will not
compile.

[Just giving the info in case it comes up with anyone else.. or if -g
-ggdb is used in the beta test build system later.]

Note You need to log in before you can comment on or make changes to this bug.