Bug 1140447 - [virtio-win][viorng]should use uniformed name for WDFCoinstallerXXX.dll
Summary: [virtio-win][viorng]should use uniformed name for WDFCoinstallerXXX.dll
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Mike Bonnet
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1207417
TreeView+ depends on / blocked
 
Reported: 2014-09-11 02:23 UTC by lijin
Modified: 2015-11-24 08:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
: 1207417 (view as bug list)
Environment:
Last Closed: 2015-11-24 08:44:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description lijin 2014-09-11 02:23:24 UTC
Description of problem:
The Wdfxxx file located in win8/win8.1/2012/2012r2 folder should named WdfCo*I*nstaller01011.dll instead of WdfCo*i*nstaller01011.dll;

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-0.12.1.2-2.444.el6.x86_64
kernel-2.6.32-500.el6.x86_64
virtio-win-1.7.2-1.el6.noarch
seabios-0.6.1.2-28.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Wdfxxx file in win8/win8.1/2012/2012r2 are named as "WdfCo*i*nstaller01011.dll"
# ls viorng/w8/x86/Wdf*
viorng/w8/x86/WdfCoinstaller01011.dll
# ls viorng/w8/amd64/Wdf*
viorng/w8/amd64/WdfCoinstaller01011.dll
# ls viorng/w8.1/x86/Wdf*
viorng/w8.1/x86/WdfCoinstaller01011.dll
# ls viorng/w8.1/amd64/Wdf*
viorng/w8.1/amd64/WdfCoinstaller01011.dll
# ls viorng/2k12/amd64/Wdf*
viorng/2k12/amd64/WdfCoinstaller01011.dll
# ls viorng/2k12R2/amd64/Wdf*
viorng/2k12R2/amd64/WdfCoinstaller01011.dll

2.Wdfxxx file in win7/2k8/2k8R2 are named as "WdfCo*I*nstaller01011.dll"
# ls viorng/w7/x86/Wdf*
viorng/w7/x86/WdfCoInstaller01009.dll
# ls viorng/w7/amd64/Wdf*
viorng/w7/amd64/WdfCoInstaller01009.dll
# ls viorng/2k8/amd64/Wdf*
viorng/2k8/amd64/WdfCoInstaller01009.dll
# ls viorng/2k8/x86/Wdf*
viorng/2k8/x86/WdfCoInstaller01009.dll
# ls viorng/2k8R2/amd64/Wdf*
viorng/2k8R2/amd64/WdfCoInstaller01009.dll


Actual results:
Wdfxxx file in win8/win8.1/2012/2012r2 are named as "WdfCo*i*nstaller01011.dll"

Expected results:
The file located in win8/win8.1/2012/2012r2 folder should named WdfCo*I*nstaller01011.dll instead of WdfCo*i*nstaller01011.dll

Additional info:
this issue only existed in virtio-win-1.7.2-1.el6.noarch;
build 88 did not hit this issue.

Comment 7 lijin 2014-12-01 08:20:40 UTC
the corresponding version of viorng in virtio-win-1.7.2-1.el6 is build88,and as comment#0 said,build88 does not hit this issue.

Comment 9 Vadim Rozenfeld 2014-12-01 10:09:28 UTC
(In reply to lijin from comment #7)
> the corresponding version of viorng in virtio-win-1.7.2-1.el6 is build88,and
> as comment#0 said,build88 does not hit this issue.

Right, the driver binaries are the same, but in virtio-win-1.7.2-1.el6 for some reason WdfCoInstaller01011.dll was renamed to WdfCoinstaller01011.dll

cc'ing Mike Bonnet from Release Engineering team to comment on this issue.

Comment 11 lijin 2015-01-13 03:34:19 UTC
still hit this issue with virtio-win-1.7.3-1.el7.noarch,the viorng version is build96

Comment 18 lijin 2015-04-14 05:54:05 UTC
check with virtio-win-1.7.4-1,steps same as comment#0

actual result:
all the wdf files are named as WdfCo*I*nstaller01011.dll instead of WdfCo*i*nstaller01011.dll.

So this issue has been fixed already.

Comment 19 lijin 2015-04-14 06:18:56 UTC
change status to verified according to comment#18

Comment 21 errata-xmlrpc 2015-11-24 08:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.