Bug 1140569 - [RFE] Provide UI ability to change "Template versioning" policy for existing pools
Summary: [RFE] Provide UI ability to change "Template versioning" policy for existing ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Michal Skrivanek
QA Contact: sefi litmanovich
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-11 09:18 UTC by Tomas Dosek
Modified: 2019-10-10 09:24 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
It is now possible to update the template for an existing virtual machine pool. This enables updated templates to be deployed to all virtual machines in the pool, and the next restarted virtual machine will be based on the new template version.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:40:04 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 36505 master MERGED core: fix a lost context in VmManagementCommandBase Never
oVirt gerrit 36506 master MERGED userportal/webadmin: fix missing fields in cloner Never
oVirt gerrit 36507 master MERGED core: Editing of template version for pools Never
oVirt gerrit 36508 master MERGED core:(2) Editing of template version for pools Never
oVirt gerrit 36509 master ABANDONED restapi: Editing of template version for stateless VMs and pools Never
oVirt gerrit 36510 master MERGED userportal\webadmin: Editing of template version for pools Never
oVirt gerrit 40101 master MERGED core: Avoid permission removal during updateVmVersion Never
Red Hat Knowledge Base (Solution) 1193763 None None None Never
Red Hat Bugzilla 1294511 None None None Never

Internal Links: 1294511

Description Tomas Dosek 2014-09-11 09:18:13 UTC
Description of problem:

After upgrade of environment from previous versions customers are not allowed to change template versioning policy for the existing pools.

The constraint is rather in UI than on other levels as the change is rather trivial and manually takes only single DB query (update of template_version_number entry in vm_static table).

Version-Release number of selected component (if applicable):
3.4.2

How reproducible:
100%

Steps to Reproduce:
1. Create template with Base template version
2. Try to edit it to the latest version

Actual results:
It cannot be edited

Expected results:
It should be editable

Comment 10 Max Kovgan 2015-06-28 14:12:44 UTC
ovirt-3.6.0-3 release

Comment 14 sefi litmanovich 2016-01-11 13:31:35 UTC
Verified with rhevm-3.6.2-0.1.el6.noarch.

After creating a vm pool from template with 5 version (choose version 1 at first), changing the version is possible via ui to each of the 5 version + to the latest pointer.
Each change between version will invoke vms deletion and re creation from the new chosen version as expected.

Please notice that there is a regression on the latest pointer as can be seen in this bz:  https://bugzilla.redhat.com/show_bug.cgi?id=1294511.

Might be caused by this patch?

Comment 15 Julie 2016-02-22 07:10:00 UTC
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

Cause:
Consequence:
Fix:
Result:

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 17 errata-xmlrpc 2016-03-09 20:40:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.