Bug 1140578 - [eap6 patching] applying patches via bundles fails for Windows - wrong file path extracted
Summary: [eap6 patching] applying patches via bundles fails for Windows - wrong file p...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.3.0
Hardware: Unspecified
OS: Windows
unspecified
urgent
Target Milestone: ER04
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: JON3-10, PRODMGT-544
TreeView+ depends on / blocked
 
Reported: 2014-09-11 09:35 UTC by Garik Khachikyan
Modified: 2015-01-04 22:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:04:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Garik Khachikyan 2014-09-11 09:35:44 UTC
Description of problem:
My tries to apply the EAP6 patch tarball (via bundles) to Windows systems fails with:
===
2014-09-11 10:26:50,890 ERROR [BundleDeployment-1] (rhq.core.pc.bundle.BundleManager)- Failed to complete bundle deployment
java.io.FileNotFoundException: data\tmp\bundle-versions\10043\jboss-eap-6.2.1.CP|jboss-eap-6.2.2.CP|jboss-eap-6.2.3.CP.zip (The filename, directory name, or volume label syntax is incorrect)
	at java.io.FileOutputStream.open(Native Method)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:221)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:171)
	at org.rhq.core.pc.bundle.BundleManager.downloadBundleFiles(BundleManager.java:584)
	at org.rhq.core.pc.bundle.BundleManager.access$100(BundleManager.java:100)
	at org.rhq.core.pc.bundle.BundleManager$1.run(BundleManager.java:209)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
===

Version-Release number of selected component (if applicable):
SystemInformation: ********
ACTIVE_DRIFT_PLUGIN: [drift-jpa]
AGENT_MAX_QUIET_TIME_ALLOWED: [300000]
ALERT_PURGE: [2678400000]
AS config dir: [/home/hudson/jon-server-3.3.0.ER01.1/jbossas/standalone/configuration]
AS product name: [EAP]
AS product version: [6.3.0.GA]
AS version: [7.4.0.Final-redhat-19]
AVAILABILITY_PURGE: [31536000000]
Agent gk-jon3-10-server.bc.jonqe.lab.eng.bos.redhat.com: [Agent[id=10001,name=gk-jon3-10-server.bc.jonqe.lab.eng.bos.redhat.com,address=10.16.23.193,port=16163,remote-endpoint=socket://10.16.23.193:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1410427894452,last-availability-report=1410425577959]]
Agent gk-jon3-10-std1.bc.jonqe.lab.eng.bos.redhat.com: [Agent[id=10031,name=gk-jon3-10-std1.bc.jonqe.lab.eng.bos.redhat.com,address=10.16.23.210,port=16163,remote-endpoint=socket://10.16.23.210:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1410427870122,last-availability-report=1410403496074]]
Agent gk-win-std1: [Agent[id=10041,name=gk-win-std1,address=10.16.23.237,port=16163,remote-endpoint=socket://10.16.23.237:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1410427868082,last-availability-report=1410427668540]]
AlertCount: [1]
AlertDefinitionCount: [8]
BuildNumber: [9941660:f3aa7e7]
CAM_BASELINE_DATASET: [604800000]
CAM_BASELINE_FREQUENCY: [259200000]
CAM_BASE_URL: [http://10.16.23.193:7080/]
CAM_DATA_MAINTENANCE: [3600000]
CAM_DATA_PURGE_1D: [31536000000]
CAM_DATA_PURGE_1H: [1209600000]
CAM_DATA_PURGE_6H: [2678400000]
CAM_GUIDE_ENABLED: [true]
CAM_HELP_PASSWORD: [- non null -]
CAM_HELP_USER: [web]
CAM_JAAS_PROVIDER: [true]
CAM_LDAP_BASE_DN: [ou=Users,dc=jboss,dc=org]
CAM_LDAP_BIND_DN: []
CAM_LDAP_BIND_PW: [- non null -]
CAM_LDAP_FILTER: []
CAM_LDAP_FOLLOW_REFERRALS: [false]
CAM_LDAP_GROUP_FILTER: []
CAM_LDAP_LOGIN_PROPERTY: [uid]
CAM_LDAP_NAMING_FACTORY_INITIAL: [com.sun.jndi.ldap.LdapCtxFactory]
CAM_LDAP_NAMING_PROVIDER_URL: [ldap://web.bc.jonqe.lab.eng.bos.redhat.com:10389]
CAM_LDAP_PROTOCOL: [false]
CAM_RT_COLLECT_IP_ADDRS: [true]
CAM_SYSLOG_ACTIONS_ENABLED: [false]
DATABASE_CONNECTION_URL: [jdbc:postgresql://127.0.0.1:5432/rhq?loginTimeout=0&socketTimeout=0&prepareThreshold=5&unknownLength=2147483647&loglevel=0&tcpkeepalive=false&binaryTransfer=true]
DATABASE_DRIVER_NAME: [PostgreSQL Native Driver]
DATABASE_DRIVER_VERSION: [PostgreSQL 9.2 JDBC4 (build 1002)]
DATABASE_PRODUCT_NAME: [PostgreSQL]
DATABASE_PRODUCT_VERSION: [8.4.18]
DATA_REINDEX_NIGHTLY: [false]
DB_SCHEMA_VERSION: [2.157]
DRIFT_FILE_PURGE: [2678400000]
ENABLE_AGENT_AUTO_UPDATE: [true]
ENABLE_LOGIN_WITHOUT_ROLES: [false]
EVENT_PURGE: [1209600000]
FullName: [JBoss Operations Network]
Name: [JBoss ON]
OPERATION_HISTORY_PURGE: [0]
PlatformCount: [3]
RESOURCE_GENERIC_PROPERTIES_UPGRADE: [false]
RHQ_SESSION_TIMEOUT: [3600000]
RT_DATA_PURGE: [2678400000]
SERVER_HOME_DIR: [/home/hudson/jon-server-3.3.0.ER01.1/jbossas/standalone]
SERVER_IDENTITY: [gk-jon3-10-server.bc.jonqe.lab.eng.bos.redhat.com]
SERVER_INSTALL_DIR: [/home/hudson/jon-server-3.3.0.ER01.1]
SERVER_LOCAL_TIME: [September 11, 2014 5:31:59 AM EDT]
SERVER_TIMEZONE: [Eastern Standard Time]
SERVER_VERSION: [4.12.0.JON330ER01]
SchedulesPerMinute: [198]
ServerCount: [12]
ServiceCount: [1122]
Storage_Node gk-jon3-10-server.bc.jonqe.lab.eng.bos.redhat.com: [storageNode.addresss=gk-jon3-10-server.bc.jonqe.lab.eng.bos.redhat.com, hostname=gk-jon3-10-server.bc.jonqe.lab.eng.bos.redhat.com, beginTime=1410399121376, beginTime=1410399121376, unackAlerts=1, heapUsed=null, heapPercentageUsed=Min: 0.1540012961336536, Max: 0.7931249138111464, Avg: 0.47685833703176195 (%), load=null, dataUsedPercentage=null, dataDiskUsed=null, tokens=null, actuallyOwns=null]
TRAIT_PURGE: [31536000000]
Version: [3.3.0.ER01.1]
********

How reproducible:
always on Windows systems

Steps to Reproduce:
1. create a bundle via uploading jboss-eap-6.2.3-patch.zip (you may get it from Customer Portal)
2. make a compatible group and add the EPA6 Controller of your Standalone Windows server to there.
3. try to deploy that bundle

Actual results:
fails - above.

Expected results:
should pass, jboss-cli patch info should reflect correctly the procedure completed there.

Additional info:
I set it really urgent as all current checks with Windows systems blocked by this and have a fairly big impact.

Comment 2 Thomas Segismont 2014-09-19 12:25:12 UTC
Probably because Windows file names cannot contain "|"

Comment 3 Thomas Segismont 2014-09-19 12:56:52 UTC
Fixed in master

commit ca6bff8e976166de5d1fc7d604822376193cbb9e
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Fri Sep 19 14:55:56 2014 +0200
    
    Use hash sign as separator instead of pipe.
    
    Tested on Windows2008R2

Comment 4 Lukas Krejci 2014-09-22 20:49:08 UTC
commit 22c989095f0190f1dbaee00f38ffaf5f257ce5ed
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Fri Sep 19 14:55:56 2014 +0200

    Bug 1140578 - [eap6 patching] applying patches via bundles fails for Windows - wrong file path extracted
    
    Use hash sign as separator instead of pipe.
    
    Tested on Windows2008R2
    
    (cherry picked from commit ca6bff8e976166de5d1fc7d604822376193cbb9e)
    Signed-off-by: Lukas Krejci <lkrejci@redhat.com>

Comment 5 Lukas Krejci 2014-09-22 20:49:44 UTC
master: 6f5c3811fd1d15e1ce76c53f82cb43ee07f6610f
release/jon3.3.x: e5579a170ad0008b40f2ab589ee802d041dec3e5
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Mon Sep 22 22:40:44 2014 +0200

    [BZ 1140578] Change the patch name delimiter also on the agent-side.
    
    (cherry picked from commit 6f5c3811fd1d15e1ce76c53f82cb43ee07f6610f)

Comment 6 Simeon Pinder 2014-10-01 21:33:11 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 8 Garik Khachikyan 2014-10-13 11:52:58 UTC
# VERIFIED

tried for both linux and windows-based Standalone machines - works fine with both cases. Final version after patch upgrade gets to the 6.2.3.GA as expected.


version
===
07:52:43,467 INFO  [SystemInfoManager] (http-/0.0.0.0:7080-3) SystemInformation: ********
ACTIVE_DRIFT_PLUGIN: [drift-jpa]
AGENT_MAX_QUIET_TIME_ALLOWED: [300000]
ALERT_PURGE: [2678400000]
AS config dir: [/home/hudson/jon-server-3.3.0.ER04/jbossas/standalone/configuration]
AS product name: [EAP]
AS product version: [6.3.0.GA]
AS version: [7.4.0.Final-redhat-19]
AVAILABILITY_PURGE: [31536000000]
Agent gk-agent1.bc.jonqe.lab.eng.bos.redhat.com: [Agent[id=10011,name=gk-agent1.bc.jonqe.lab.eng.bos.redhat.com,address=10.16.23.143,port=16163,remote-endpoint=socket://10.16.23.143:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1413201121628,last-availability-report=1412689182899]]
Agent gk-agent2.bc.jonqe.lab.eng.bos.redhat.com: [Agent[id=10031,name=gk-agent2.bc.jonqe.lab.eng.bos.redhat.com,address=10.16.23.90,port=16163,remote-endpoint=socket://10.16.23.90:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1413201117588,last-availability-report=1413200388429]]
Agent gk-server1.bc.jonqe.lab.eng.bos.redhat.com: [Agent[id=10001,name=gk-server1.bc.jonqe.lab.eng.bos.redhat.com,address=10.16.23.123,port=16163,remote-endpoint=socket://10.16.23.123:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1413201110711,last-availability-report=1412595619215]]
Agent gk-win1: [Agent[id=10021,name=gk-win1,address=10.16.23.221,port=16163,remote-endpoint=socket://10.16.23.221:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200,last-availability-ping=1413201130339,last-availability-report=1413197572942]]
AlertCount: [2]
AlertDefinitionCount: [8]
BuildNumber: [99d2107:d7c537e]
CAM_BASELINE_DATASET: [604800000]
CAM_BASELINE_FREQUENCY: [259200000]
CAM_BASE_URL: [http://gk-server1.bc.jonqe.lab.eng.bos.redhat.com:7080/]
CAM_DATA_MAINTENANCE: [3600000]
CAM_DATA_PURGE_1D: [31536000000]
CAM_DATA_PURGE_1H: [1209600000]
CAM_DATA_PURGE_6H: [2678400000]
CAM_GUIDE_ENABLED: [true]
CAM_HELP_PASSWORD: [- non null -]
CAM_HELP_USER: [web]
CAM_JAAS_PROVIDER: [false]
CAM_LDAP_BASE_DN: [o=JBoss,c=US]
CAM_LDAP_BIND_DN: []
CAM_LDAP_BIND_PW: [- non null -]
CAM_LDAP_FILTER: []
CAM_LDAP_FOLLOW_REFERRALS: [false]
CAM_LDAP_LOGIN_PROPERTY: [cn]
CAM_LDAP_NAMING_FACTORY_INITIAL: [com.sun.jndi.ldap.LdapCtxFactory]
CAM_LDAP_NAMING_PROVIDER_URL: [ldap://localhost/]
CAM_LDAP_PROTOCOL: [false]
CAM_RT_COLLECT_IP_ADDRS: [true]
CAM_SYSLOG_ACTIONS_ENABLED: [false]
DATABASE_CONNECTION_URL: [jdbc:postgresql://127.0.0.1:5432/rhq?loginTimeout=0&socketTimeout=0&prepareThreshold=5&unknownLength=2147483647&loglevel=0&tcpkeepalive=false&binaryTransfer=true]
DATABASE_DRIVER_NAME: [PostgreSQL Native Driver]
DATABASE_DRIVER_VERSION: [PostgreSQL 9.2 JDBC4 (build 1002)]
DATABASE_PRODUCT_NAME: [PostgreSQL]
DATABASE_PRODUCT_VERSION: [9.2.7]
DATA_REINDEX_NIGHTLY: [false]
DB_SCHEMA_VERSION: [2.161]
DRIFT_FILE_PURGE: [2678400000]
ENABLE_AGENT_AUTO_UPDATE: [true]
ENABLE_LOGIN_WITHOUT_ROLES: [true]
EVENT_PURGE: [1209600000]
FullName: [JBoss Operations Network]
Name: [JBoss ON]
OPERATION_HISTORY_PURGE: [0]
PlatformCount: [4]
RESOURCE_GENERIC_PROPERTIES_UPGRADE: [false]
RHQ_SESSION_TIMEOUT: [3600000]
RT_DATA_PURGE: [2678400000]
SERVER_HOME_DIR: [/home/hudson/jon-server-3.3.0.ER04/jbossas/standalone]
SERVER_IDENTITY: [gk-server1.bc.jonqe.lab.eng.bos.redhat.com]
SERVER_INSTALL_DIR: [/home/hudson/jon-server-3.3.0.ER04]
SERVER_LOCAL_TIME: [October 13, 2014 7:52:42 AM EDT]
SERVER_TIMEZONE: [Eastern Standard Time]
SERVER_VERSION: [4.12.0.JON330ER04]
SchedulesPerMinute: [188]
ServerCount: [17]
ServiceCount: [1600]
Storage_Node gk-server1.bc.jonqe.lab.eng.bos.redhat.com: [storageNode.addresss=gk-server1.bc.jonqe.lab.eng.bos.redhat.com, hostname=gk-server1.bc.jonqe.lab.eng.bos.redhat.com, beginTime=1413172363247, beginTime=1413172363247, unackAlerts=2, heapUsed=null, heapPercentageUsed=Min: 0.23676076553795536, Max: 0.7710225311111198, Avg: 0.48970202773813903 (%), load=null, dataUsedPercentage=null, dataDiskUsed=null, tokens=null, actuallyOwns=null]
TRAIT_PURGE: [31536000000]
Version: [3.3.0.ER04]
********
===


Note You need to log in before you can comment on or make changes to this bug.