Bug 114063 - vncconfig -connect fails
vncconfig -connect fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 20:41 EST by John Franks
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.0-0.beta4.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-23 12:24:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of strace of Xvnc (31.20 KB, text/plain)
2004-01-22 09:40 EST, John Franks
no flags Details
Revised vnc-restart.patch (719 bytes, patch)
2004-01-23 11:04 EST, John Franks
no flags Details | Diff

  None (edit)
Description John Franks 2004-01-21 20:41:43 EST
Description of problem:
With vncserver running attempts to make a reverse connection
to host1 using "vncconfig -display whatever:x -connect host1" fail.

The log shows:
vncext:      Reverse connection: unable to connect to
host: Interrupted system call (4)


This works properly if vncconnect from RH9 is used on the server end
and FC1 is the listener.

Google indicates others have seen this problem.  cf.
http://www.realvnc.com/pipermail/vnc-list/2003-December/042255.html

Version-Release number of selected component (if applicable):
vnc-4.0-0.beta4.3.2.i386  on both ends with both ends using
FC1.

How reproducible:
always

Steps to Reproduce:
1. On locla run "vncserver :1"
2. On remote run "vncviewer -listen"
3. On local run "vncconfig -display :1 -connect remote"
  
Actual results:
No connection, log as above.

Expected results:
Connection

Additional info:
Comment 1 Tim Waugh 2004-01-22 07:26:08 EST
Hmm, I don't see this here.

Could you please run 'strace -p PID 2>log' (with the process ID of
Xvnc substituted for PID) just before running vncconfig, and stop it
with Ctrl-C once the connection fails?  Then please attach the 'log' file.

It'll be that some signal interrupts the connect() system call, but
depending on who set the signal (us, or X) we can either fix the
signal set up or try the connection again.
Comment 2 John Franks 2004-01-22 09:40:59 EST
Created attachment 97163 [details]
Output of strace of Xvnc

As requested this was generated by

  strace -p Xvnc_PID 2>log

After starting strace I ran 
  vncconfig -display :1 -connect <hostname>
Comment 3 Tim Waugh 2004-01-22 10:58:29 EST
I think this might be fixed in vnc-4.0-0.beta4.7, which should show up
in rawhide in the next day or two.  Please let me know.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/
Comment 4 John Franks 2004-01-23 09:35:27 EST
Well, it is not fixed, but improved.  Using vnc-4.0.0.beta4.7 a
connection can be made about every third try.  It is at least usable
now as I can always connect in two or three tries.  The failures
appear identical to the previous situation.
Comment 5 Tim Waugh 2004-01-23 09:59:42 EST
I think the vnc-restart.patch file should use EINTR instead of
ERESTART.  I'll build a new package.
Comment 6 John Franks 2004-01-23 11:04:45 EST
Created attachment 97212 [details]
Revised vnc-restart.patch

You seem to be right!  I downloaded the beta4.7.src rpm and revised
your patch replacing 

    if (e == ERESTART)

with 

    if ((e == ERESTART) || (e == EINTR))

and built a binary rpm.  The result works like a charm.
The revised vnc-restart.patch is attached.
Comment 7 Tim Waugh 2004-01-23 12:13:00 EST
Great.  Just to be sure, could you please try these packages?:

http://cyberelk.net/tim/data/tmp/vnc-4.0-0.beta4.8.i386.rpm
http://cyberelk.net/tim/data/tmp/vnc-server-4.0-0.beta4.8.i386.rpm

They simple replace ERESTART with EINTR.  I don't think that the
application is ever meant to see ERESTART.
Comment 8 John Franks 2004-01-23 12:24:25 EST
I tried 4.0-0.beta4.8 and it works fine.  The problem seems to be
solved. Thanks.
Comment 9 Tim Waugh 2004-01-23 12:26:40 EST
Great.  Patch submitted upstream.

Note You need to log in before you can comment on or make changes to this bug.