Bug 11408 - default gateway
Summary: default gateway
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-14 14:28 UTC by Alain Wenmaekers
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-04 05:30:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alain Wenmaekers 2000-05-14 14:28:08 UTC
If you enter a default gateway in linuxconf, and you do "activate
configuration", the new setting doesn't work.

after doing a "route" i see that the route to the default gateway isn't in
there.

I usually reboot (the windows NT method ;-), and it works then...but I
guess it is possible to add it manually in the route table.

Actually it's rather confusing that almost every change works immediately,
except this one...

Comment 1 Nalin Dahyabhai 2000-05-22 17:50:59 UTC
The default route is only set when the interface that the route is on is
brought up.  Take the interface down and bring it back up (something which
should get done if you change the interface's address or netmask), and your
route should get set.

Comment 2 monica 2000-06-04 05:30:06 UTC
Every time I use Linuxconf to edit any parameter, my routing table is EMPTIED, 
with the exception of the localhost.  I then lose all network and internet 
connectivity, and it is impossible to add a route via the route daemon.  The 
only solution I have found is to use netconfig.  HOWEVER, watch out because the 
default gateway and nameserver are auto-filled incorrectly!

Comment 3 Brent Fox 2002-06-05 01:37:19 UTC
I'm going to close this bug since we don't ship linuxconf anymore (thank heavens).


Note You need to log in before you can comment on or make changes to this bug.