Bug 1140823 - /etc/pulp/repo_auth.conf doesn't have in-code defaults like our other config files have
Summary: /etc/pulp/repo_auth.conf doesn't have in-code defaults like our other config ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: rpm-support
Version: Master
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-11 18:42 UTC by Randy Barlow
Modified: 2015-02-28 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:19:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 518 None None None Never

Description Randy Barlow 2014-09-11 18:42:40 UTC
Description of problem:
Currently there is no way to specify all of the config defaults for repo_auth.conf. In fact, most of those settings are required to be present, or the WSGI access script will fail.

Version-Release number of selected component (if applicable):
2.4.0

How reproducible:
Every time

Steps to Reproduce:
1. Make repo_auth.py empty.
2. Restart apache.
3. Try to access a protected repository.

Actual results:
The access script will fail due to the values in repo_auth being required.

Expected results:
There should be sane defaults for all settings in repo_auth.conf.

Comment 1 Brian Bouterse 2015-02-28 22:19:11 UTC
Moved to https://pulp.plan.io/issues/518


Note You need to log in before you can comment on or make changes to this bug.