Bug 1141 - xconsole is not 8 bit clean
xconsole is not 8 bit clean
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Depends On:
  Show dependency treegraph
Reported: 1999-02-13 01:12 EST by Marc MERLIN
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-16 16:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 1999-02-13 01:12:47 EST
To reproduce: echo "resumi" > /dev/console

This is a problem insofar as I have some syslog messages
are redirected to the console, and my locale is set to
French, so syslog messages get butchered when I see them
in my xconsole.
Comment 1 David Lawrence 1999-03-12 18:10:59 EST
I was unable to replicate this problem in our test lab.
Comment 2 Marc MERLIN 1999-04-14 02:28:59 EDT
I tried again with starbuck's xconsole, and it's the same.
Here's a simple test case, please try it out:
echo -e 'a\na1i3\nb' > /dev/console

note that 1 and 3 are not supposed to touch one another.

In case this should make a difference:
moremagic:~$ echo $LC_ALL
moremagic:~$ echo $LANG

If you tell me this also works for you, I'll drop the case, and assume
something is broken on my side.
Comment 3 Marc MERLIN 1999-06-07 02:16:59 EDT
Ok, I tried again on a straight 6.0 install and the problem is really
there, I'm not sure why dkl wasn't able to reproduce the bug.

I simply did:
- startx (gdm is broken and doesn't chown the console to the user who
  logs in, so xconsole can't work. That's a separate problem though)
- launch xconsole
- echo ripertoire >/dev/console

What shows up on the xconsole is rpertoire...
Comment 4 Jay Turner 1999-06-29 14:10:59 EDT
Confirmed in test lab with XFree86-
Comment 5 Preston Brown 1999-08-16 16:53:59 EDT
This will be fixed in the next release of XFree86.

Note You need to log in before you can comment on or make changes to this bug.