Bug 11410 - packages with pre scripts not installed
packages with pre scripts not installed
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-14 13:26 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-13 15:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-05-14 13:26:06 EDT
I'm not quite sure if this is bug or if I did something that I should not
have done ... anyway:

I modified the bootdisk to not install /usr but get it via NFS. This is
done by using the netsharedpath in the rpm macros file This makes that
nothing is installed in /usr. (had some nice discussions with the RHAT
support team about this ... somehow I didn't manage to make clear why I
even want to do something like this .. ;) ).

The only other thing that I did change was to change one line in todo.py
and to add one other:

I did add /usr to the list of files that are generated right after mounting
the root partition ( that is I added it to the for loop that calls
os.mkdir(self.instPath + i) ).

Right after the loop I do a
os.system("/usr/bin/mount NFS-Server:/my/path /mnt/sysimage/usr")
to mount the /usr directory (ok, should have used self.instPath for that -
will change that .. ;) ).
(I had to slightly modify the filesystem package to not include any /usr
directories.)
I had massive problems with installation - sometimes the Installation
exited after Package Installation with signal 11, sometimes it hang (under
X).
Using text mode I could see that files in /etc/sysconfig could not be
created.

After some time I found out that some packages were not installed. I had
looked at install.log before, but there I could only see the usual
"Installing [package].". However, when I chrooted to the install root
and did query all the packages against this list I did find out that some
packages were not installed correctly:

MAKEDEV
utemper
XFree86
initscripts
XFree86-xfs
am-utils
dev
gdm
glibc-devel
kernel
ld
linuxconf
piranha
piranha-gui
postgresql-server
pvm
rootfiles
slocate
squid

I had a look at those packages and noted that all these packages had %pre
scripts (I did modify the packages to not run these scripts as none of them
are necessary for installation but only for updates (except for the useradd
and groupadd commands - but these can be directly integrated in the
setup package -- however, this is not quite ideal ...).


Big question: my fault (did I do something wrong), generally not supported
by the red hat installation or a bug in anaconda?

(Genereally, and even more because it is already there in rpm, I think it
would be very good for RHAT to have something like this. You can see this
in all major Unix distributions. It's very easy to build thin clients this
way. You need 200 MB max harddisk and have a Red Hat installation with
every package installed because most things are on the NFS server.
The changes would probably not be too hard - I even managed it ... ;) (ok,
I did not do any dialogs for this, not to mention a systematical
integration in anaconda, but it works - of course a smart implementation
would be "a bit" ;) more work ...). Especially in combination with
kickstart this is very useful. You just have to make sure that the RPMS are
in sync with your server, but this is easily done usingautorpm and rsync
Scripts (this way you can even centrally managed virtually every file of
the client)).

Michael
Comment 1 Jay Turner 2000-05-15 13:34:59 EDT
Forwarding this issue to a developer for further action.
Comment 2 Michael Redinger 2000-05-16 11:51:59 EDT
Ok, I did do my workaround. And after system restart gdm said it didn't find
libX11. After a quick check I noticed that ld.so.conf was missing. I do not know
if this is the problem or if this is caused by another problem itself. Which
package should normally create /etc/ld.so.conf? It is not owned by any package.
Comment 3 Michael Redinger 2000-05-16 14:01:59 EDT
I now checked the RPM packages. It seems that quite a few programs should write
to ld.so.conf in their post install scripts. Does this mean they don't get
executed but this does not lead to any error??
Comment 4 Michael Redinger 2000-05-17 04:32:59 EDT
A veryfied everything above. The packages listed above are the only packages
that do contain pre installation scripts. That is the installer seems to fail on
pre install scripts.

In addition I listed all the post install scripts and checked quite a lot of
them - none of them seems to have been executed.

The same possibly holds true for every other installation script. The trigger
script of qt2 wasn't executed either (this is the only package containing such a
script).

I didn't test uninstall and update scripts as this is a new system (and I do not
want to install an old one and start this whole thing on that if not really
necessary), but I suppose there would be similar (if not the same) errors.
Comment 5 Erik Troan 2000-08-17 14:25:18 EDT
These work fine for us...

Note You need to log in before you can comment on or make changes to this bug.