Bug 114102 - No i386 version of libfl avaialble in AMD64 distribution
Summary: No i386 version of libfl avaialble in AMD64 distribution
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: dff
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 126849
TreeView+ depends on / blocked
 
Reported: 2004-01-22 17:12 UTC by Göran Uddeborg
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 21:52:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Göran Uddeborg 2004-01-22 17:12:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The AMD64 distribution does not contain any i386 versions of the
libl.a and libfl.a libraries contained in the package flex.

Version-Release number of selected component (if applicable):
WS3

How reproducible:
Always

Steps to Reproduce:
1. /bin/arch
x86_64

2.rpm --redhatprovides /usr/lib/libfl.a
error: file /usr/lib/libfl.a: No such file or directory

3.rpm --redhatprovides /usr/lib64/libfl.a
flex-2.5.4a-29

Comment 1 Bill Nottingham 2004-07-01 15:38:42 UTC
What are you building that requires building against flex?

Comment 2 Göran Uddeborg 2004-07-07 17:10:15 UTC
Nothing any more. :-)

We had an old application which did use yywrap from libfl.  When we
started building on x86_64 with i386 as target we encountered this
problem.  But we did some obvious trivial changes so we no longer do
link with -lfl.

It would still be needed to use x86_64 as a compatible development
platform, so I would still argue it is a bug.  But it doesn't have any
high priority any more from our point of view.

Comment 3 dff 2004-10-29 21:52:18 UTC
Closing not a bug per earlier comments, no plans to add 32-bit flex package to
x86-64 RHEL 3 distro at this time.


Note You need to log in before you can comment on or make changes to this bug.