Bug 114109 - up2date rewrites configuration file when run
up2date rewrites configuration file when run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-22 12:57 EST by James Bourne
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 18:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bourne 2004-01-22 12:57:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
We have an rhn proxy server on site, but /etc/sysconfig/rhn/up2date is
re-written each time up2date run, which means our settings to relay
through our local rhn proxy are removed.


Version-Release number of selected component (if applicable):
2.9.3-2.2.1AS

How reproducible:
Always

Steps to Reproduce:
1. Change /etc/sysconfig/rhn/up2date to have local rhn proxy server
for http and https URLs (http[s]://rhn.mtroyal.ca/XMLRPC)
2. Copy new up2date to up2date.bak
3. Run up2date -l (or any other command)
4. diff -u up2date.bak up2date
    

Actual Results:  bash# diff -u up2date up2date.bak 
--- up2date     Thu Jan 22 10:58:36 2004
+++ up2date.bak Thu Jan 22 10:58:34 2004
@@ -61,7 +61,7 @@
 enableProxyAuth=0
 
 noSSLServerURL[comment]=Remote server URL without SSL
-noSSLServerURL=http://xmlrpc.rhn.redhat.com/XMLRPC
+noSSLServerURL=http://rhn.mtroyal.ca/XMLRPC
 
 noReplaceConfig[comment]=When selected, no packages that would change
configuration data are automatically installed
 noReplaceConfig=1
@@ -76,7 +76,7 @@
 systemIdPath=/etc/sysconfig/rhn/systemid
 
 serverURL[comment]=Remote server URL
-serverURL=https://xmlrpc.rhn.redhat.com/XMLRPC
+serverURL=https://rhn.mtroyal.ca/XMLRPC
 
 pkgSkipList[comment]=A list of package names, optionally including
wildcards, to skip
 pkgSkipList=kernel*;


Expected Results:  no output

Additional info:

This is since the last update.

Note You need to log in before you can comment on or make changes to this bug.