Bug 1141175 - Failed to install JON if jboss.bind.address.management=0.0.0.0
Summary: Failed to install JON if jboss.bind.address.management=0.0.0.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Installer
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: John Mazzitelli
QA Contact: Jeeva Kandasamy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-12 11:44 UTC by Jeeva Kandasamy
Modified: 2014-12-11 14:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:00:37 UTC
Type: Bug


Attachments (Terms of Use)
installation-fail (31.56 KB, text/plain)
2014-09-12 11:44 UTC, Jeeva Kandasamy
no flags Details
install-success (22.56 KB, text/plain)
2014-10-06 11:53 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-09-12 11:44:14 UTC
Created attachment 936931 [details]
installation-fail

Description of problem:
Installation failed if the jboss management interface set to 0.0.0.0 (jboss.bind.address.management=0.0.0.0).

ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now exit due to previous errors: java.lang.Exception: Cannot obtain client connection to the RHQ app server!!

I can install successfully when I use hostname or public IP of the host as management bind interface(jboss.bind.address.management).

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.ER02
Build Number : 4fbb183:7da54e2
GWT Version : 2.5.0
SmartGWT Version : 3.0p

How reproducible:
always

Steps to Reproduce:
1. Set jboss.bind.address.management=0.0.0.0 in rhq-server.properties
2. run ./rhqctl install

Additional info: server error log is attached.

Comment 1 John Mazzitelli 2014-09-15 21:02:52 UTC
Actually, it is not recommended that customers change that from the local loopback adderss because under normal circumstances, you don't want remote clients able to connect to the JON Server over the management interface.

But, just in case someone has a legitimate reason for doing this, I fixed it so the installer will still work if the management bind address binds to all adapters ("0.0.0.0")

committed to master:

commit 801f6cb172d9b313383fbf58d2cce55123ab6c66
Author: John Mazzitelli <mazz@redhat.com>
Date:   Mon Sep 15 17:00:45 2014 -0400

    BZ 1141175 - make sure installer works even if the management bind address is set to 0.0.0.0

Comment 2 John Mazzitelli 2014-09-15 22:38:17 UTC
3.3 branch commit:

commit aaa3f789bb81fa3322a529e1f771dea5a75936ec
Author: John Mazzitelli <mazz@redhat.com>
Date:   Mon Sep 15 17:00:45 2014 -0400

    BZ 1141175 - make sure installer works even if the management bind address is set to 0.0.0.0
    (cherry picked from commit 801f6cb172d9b313383fbf58d2cce55123ab6c66)

Comment 3 Simeon Pinder 2014-10-01 21:33:42 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 4 Jeeva Kandasamy 2014-10-06 11:53:57 UTC
Created attachment 944217 [details]
install-success

Version:
JBoss Operations Network
Version : 3.3.0.ER04
Build Number : 99d2107:d7c537e
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Works as expected. Installation is attached.


Note You need to log in before you can comment on or make changes to this bug.