Bug 114136 - Package totals off by one
Summary: Package totals off by one
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-22 22:32 UTC by Mike McLean
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 23:42:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (full_server-install-english-ftp-TUI) (49.64 KB, text/plain)
2004-01-22 22:34 UTC, Mike McLean
no flags Details

Description Mike McLean 2004-01-22 22:32:37 UTC
* rawhide-20040122.mikem (0122 + new initrd)

Package totals in some installs are one higher that the number of
packages listed as installed in the log.

My first thought was comps, but there seems to be no comps package in
any of the logs, even the ones with correct package totals.  (Although
there is comps-extras).

Installs with correct package totals:
minimal-french-nfs-TUI
desktop-install-german-nfs-GUI
root_fs_on_lvm-english-http-TUI

Installs with incorrect package totals:
raid0_install-russian-ftp-GUI
raid1_on_root-italian-ftp-TUI
full_server-install-english-ftp-TUI

I see no particular pattern offhand.

Comment 1 Mike McLean 2004-01-22 22:34:14 UTC
Created attachment 97198 [details]
install.log (full_server-install-english-ftp-TUI)

Comment 3 Mike McLean 2004-01-23 23:26:22 UTC
fwiw, FC2-re0122.0 had precisely the same testcases encounter the error.

Comment 4 Jeremy Katz 2004-02-17 23:43:01 UTC
Still happening?

Comment 5 Mike McLean 2004-02-18 17:39:58 UTC
The problem does not occur in the more recent FC2 trees.

However, the rawhide trees are another story.  It looks like every
rawhide tree since has manifested the bug.  Always the same three
testcases too: raid0_install, raid1_on_root, and RH-full_server.



Comment 7 Jeremy Katz 2004-02-18 18:39:47 UTC
Aha, it's because rawhide trees don't end up with a comps.rpm while
the FC2 trees do.  And via ftp, I get a file for comps.rpm and so bump
my number of packages by one, even though it's ridiculous and
non-existent.

Low priority to actually fix this since it shouldn't happen with a
"well-formed" tree (and even when it does, it's cosmetic).  And I'll
bug notting/sopwith about getting comps packages built for rawhide.

Comment 8 Mike McLean 2004-02-18 19:37:18 UTC
I've run some additional tests today.  Not all ftp installs produce
the problem.


Note You need to log in before you can comment on or make changes to this bug.