Bug 114150 - libdb-4.1.so broken in compat-db
Summary: libdb-4.1.so broken in compat-db
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: compat-db   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 135876
TreeView+ depends on / blocked
 
Reported: 2004-01-23 09:10 UTC by Joe Orton
Modified: 2007-04-18 17:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 17:59:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2004-01-23 09:10:00 UTC
After upgrading to db-4.2.52 and compat-db-4.1.25:

# rpm -q compat-db
compat-db-4.1.25-1
# /etc/cron.daily/cyrus-imapd
bash: /root/.bashrc: Permission denied
/usr/cyrus/bin/ctl_deliver: relocation error: /lib/libdb-4.1.so:
undefined symbol: pthread_mutex_trylock

may be simply because libdb-4.1.so does not have a DT_NEEDED for
libpthread.so

# ldd /lib/libdb-4.1.so
        libc.so.6 => /lib/tls/libc.so.6 (0x00761000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00749000)

Comment 1 Jeff Johnson 2004-01-23 09:16:37 UTC
There are 2 problems: 
    cyrus-imapd needs link against db-4.2.52
    db-4.1.25 needs link against pthreads.

Comment 2 Joe Orton 2004-11-05 11:41:43 UTC
Still present in Raw Hide...

# rpm -qf /lib/libdb-4.1.so
compat-db-4.1.25-6
# ldd -d -r /lib/libdb-4.1.so
undefined symbol: pthread_condattr_setpshared   (/lib/libdb-4.1.so)
undefined symbol: pthread_mutexattr_destroy     (/lib/libdb-4.1.so)
undefined symbol: pthread_mutexattr_setpshared  (/lib/libdb-4.1.so)
undefined symbol: pthread_mutexattr_init        (/lib/libdb-4.1.so)
undefined symbol: pthread_mutex_trylock (/lib/libdb-4.1.so)
        libc.so.6 => /lib/tls/libc.so.6 (0x00132000)
        /lib/ld-linux.so.2 (0x00115000)


Comment 6 Jeff Johnson 2004-11-14 13:27:22 UTC
Fixed by linking -lpthread in compat-db-4.1.25-7.


Comment 8 Jeff Johnson 2004-11-15 17:59:00 UTC
ExcludeArch: ia64 removed in compat-db-4.1.25-8 build for RHEL-4.


Note You need to log in before you can comment on or make changes to this bug.