Bug 1141523 - SELinux context not syncing
Summary: SELinux context not syncing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: profile-sync-daemon
Version: 21
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-14 11:51 UTC by rvcsaba
Modified: 2014-09-27 09:57 UTC (History)
1 user (show)

Fixed In Version: profile-sync-daemon-5.51-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-27 09:50:16 UTC


Attachments (Terms of Use)
selinux-context.patch (824 bytes, patch)
2014-09-14 12:04 UTC, rvcsaba
no flags Details | Diff

Description rvcsaba 2014-09-14 11:51:41 UTC
Description of problem:

I use this smart daemon, but get a message:

SELinux is preventing /usr/lib64/firefox/plugin-container from open access on the file /tmp/csaba-firefox-wvpulgb2.default/cert8.db


Version-Release number of selected component (if applicable):

profile-sync-daemon-5.50-1.fc21.noarch


How reproducible:

I use firefox.


Steps to Reproduce:
1.
2.
3.

Actual results:

SELinux context not syncing


Additional info:

Please use in do_sync() function rsync -X switch, because "-X" syncing SELinux context too.

Comment 1 rvcsaba 2014-09-14 12:04:41 UTC
Created attachment 937317 [details]
selinux-context.patch

My patch. It work.

Comment 2 Christopher Meng 2014-09-14 22:40:45 UTC
Thanks for the report.

I will discuss with upstream about this.

Comment 3 Fedora Update System 2014-09-17 04:53:09 UTC
profile-sync-daemon-5.51-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-10810/profile-sync-daemon-5.51-1.fc21

Comment 4 Fedora Update System 2014-09-17 04:53:17 UTC
profile-sync-daemon-5.51-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-10822/profile-sync-daemon-5.51-1.fc20

Comment 5 Fedora Update System 2014-09-17 04:53:18 UTC
profile-sync-daemon-5.51-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/profile-sync-daemon-5.51-1.fc19

Comment 6 Fedora Update System 2014-09-18 16:12:13 UTC
Package profile-sync-daemon-5.51-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing profile-sync-daemon-5.51-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10810/profile-sync-daemon-5.51-1.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-09-27 09:50:16 UTC
profile-sync-daemon-5.51-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-09-27 09:55:42 UTC
profile-sync-daemon-5.51-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-09-27 09:57:41 UTC
profile-sync-daemon-5.51-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.