Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1141529 - Review Request: php-horde-passwd - Horde password changing application
Review Request: php-horde-passwd - Horde password changing application
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shawn Iwinski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-14 08:59 EDT by Remi Collet
Modified: 2014-12-26 14:52 EST (History)
2 users (show)

See Also:
Fixed In Version: php-horde-passwd-5.0.2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-20 03:37:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shawn: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)
phpcompatinfo.log (20.00 KB, text/plain)
2014-12-07 13:43 EST, Shawn Iwinski
no flags Details
fedora-review.txt (8.38 KB, text/plain)
2014-12-07 13:44 EST, Shawn Iwinski
no flags Details

  None (edit)
Description Remi Collet 2014-09-14 08:59:41 EDT
Spec URL: https://raw.githubusercontent.com/remicollet/remirepo/66754ad66db78c5d0985822c53218f9e08070a32/php/horde/php-horde-passwd/php-horde-passwd.spec
SRPM URL: http://rpms.famillecollet.com/SRPMS/php-horde-passwd-5.0.2-1.remi.src.rpm
Description: 
An application to change any user passwords stored in various backends like
SQL, LDAP, Kolab, passwd files etc.

Fedora Account System Username: remi
Comment 1 Shawn Iwinski 2014-12-07 13:43:13 EST
Created attachment 965606 [details]
phpcompatinfo.log

phpcompatinfo version 2.26.0
Comment 2 Shawn Iwinski 2014-12-07 13:44:22 EST
Created attachment 965607 [details]
fedora-review.txt

Generated by fedora-review 0.5.2 (63c24cb) last change: 2014-07-14
Command line :/usr/bin/fedora-review --mock-config fedora-rawhide-x86_64 -b 1141529
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, PHP, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG
Comment 3 Shawn Iwinski 2014-12-07 13:47:16 EST
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[!]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[!]: Buildroot is not present
     Note: Buildroot: present but not needed
[!]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: %clean present but not required

As usual, remove EPEL 5 bits after initial import.



[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

     W: conffile-without-noreplace-flag /etc/horde/passwd/conf.xml
     %attr(0660,apache,apache) %config %{_sysconfdir}/horde/%{pear_name}/*.xml

     Since the permission of this config file is 0660 instead of 0640, it
     implies that this file can be edited by end-users.  However, without
     "%config(noreplace)" end-users' edits would be lost.

Just a warning, but you may want to address this.



No blockers.



===== APPROVED =====
Comment 4 Remi Collet 2014-12-08 00:52:46 EST
Thanks!

New Package SCM Request
=======================
Package Name: php-horde-passwd
Short Description: Horde password changing application
Upstream URL: http://www.horde.org/apps/passwd
Owners: remi
Branches: f20 f21 el6 epel7
InitialCC:
Comment 5 Gwyn Ciesla 2014-12-08 08:55:28 EST
Git done (by process-git-requests).
Comment 6 Fedora Update System 2014-12-08 12:48:13 EST
php-horde-passwd-5.0.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/php-horde-passwd-5.0.2-1.fc21
Comment 7 Fedora Update System 2014-12-08 12:48:19 EST
php-horde-passwd-5.0.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-horde-passwd-5.0.2-1.fc20
Comment 8 Fedora Update System 2014-12-08 12:48:26 EST
php-horde-passwd-5.0.2-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/php-horde-passwd-5.0.2-1.el7
Comment 9 Fedora Update System 2014-12-08 12:48:34 EST
php-horde-passwd-5.0.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-horde-passwd-5.0.2-1.el6
Comment 10 Fedora Update System 2014-12-11 01:26:24 EST
php-horde-passwd-5.0.2-1.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 11 Fedora Update System 2014-12-20 03:37:30 EST
php-horde-passwd-5.0.2-1.fc20 has been pushed to the Fedora 20 stable repository.
Comment 12 Fedora Update System 2014-12-20 03:42:19 EST
php-horde-passwd-5.0.2-1.fc21 has been pushed to the Fedora 21 stable repository.
Comment 13 Fedora Update System 2014-12-26 14:49:21 EST
php-horde-passwd-5.0.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository.
Comment 14 Fedora Update System 2014-12-26 14:52:25 EST
php-horde-passwd-5.0.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.