Bug 114154 - up2date produces urlopen error -3
up2date produces urlopen error -3
Status: CLOSED DUPLICATE of bug 102272
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 06:46 EST by Volker Meyer
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volker Meyer 2004-01-23 06:46:05 EST
Description of problem:
$ up2date -l
Fetching package list for channel: fedora-core-1...

Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
There was some sort of I/O error: <urlopen error (-3, 'Temporary
failure in name resolution')>

Version-Release number of selected component (if applicable):


How reproducible:
up2date -l

Steps to Reproduce:
1. up2date -l
2.
3.
  
Actual results:
Fetching package list for channel: fedora-core-1...

Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
There was some sort of I/O error: <urlopen error (-3, 'Temporary
failure in name resolution')>


Expected results:
list of packages, or no list of packages

Additional info:
worked fine until I upgraded from redhat 9 to fedora.
Comment 1 Jef Spaleta 2004-01-28 12:10:43 EST
Okay, i just reverted my up2date back to a stock install on FC1.
I can't reproduce this. I do remember a problem early on in FC1
involving the redirects at the official fedora download site. But my
understanding is the problem was serverside and affected all the
clients who were using the default urls.  

I'm going to mark this as WORKSFORME and close the bug report. Please
try to reconfirm this problem and report back to this bug report.
AFAICT this was a temporary problem on the server, and this particular
problem should no longer be an issue (no comment about other problems
you might have with the default urls)  
Comment 2 Volker Meyer 2004-01-29 02:21:25 EST
I am so glad, that it works for you. 
Unfortunately I have to give this a WORKSFORMENOT status.

Maybe the URL's are wrong?
---
yum fedora-core-1 http://fedora.redhat.com/releases/fedora-core-1
yum updates-released
http://fedora.redhat.com/updates/released/fedora-core-1
yum updates-testing http://fedora.redhat.com/updates/testing/fedora-core-1
--
So far I checked "fedora-core-1" and get the following errors.
(I have to use a proxy, maybe that's the problem?)
---
(up2date:20689): Gdk-WARNING **: DESKTOP_STARTUP_ID contains invalid UTF-8
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1359, in
onChannelsPageNext
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 117, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 316, in
getAvaila
bleAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 156, in
available
PackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 111, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 26, in
listPackages
    return self.handlers[channel['type']].listPackages(channel,
msgCallback, pro
gressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 226, in
listPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
197, in lis
tPackages
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
257, in fe
tchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
98, in ope
n_resource
    return opener.open(request)
  File "/usr/lib/python2.2/urllib2.py", line 328, in open
    '_open', req)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.2/urllib2.py", line 824, in http_open
    return self.do_open(httplib.HTTP, req)
  File "/usr/lib/python2.2/urllib2.py", line 809, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error (-3, 'Temporary failure in name
resolution')>  File "/usr/share/rhn/up2date_client/gui.py", line 1425,
in onSkippedPagePrepar
e
    self.__preparePackageList()
  File "/usr/share/rhn/up2date_client/gui.py", line 1312, in
__preparePackageLis
t
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 117, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 316, in
getAvaila
bleAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 156, in
available
PackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 111, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 26, in
listPackages
    return self.handlers[channel['type']].listPackages(channel,
msgCallback, pro
gressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 226, in
listPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
197, in lis
tPackages
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
257, in fe
tchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
98, in ope
n_resource
    return opener.open(request)
  File "/usr/lib/python2.2/urllib2.py", line 328, in open
    '_open', req)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.2/urllib2.py", line 824, in http_open
    return self.do_open(httplib.HTTP, req)
  File "/usr/lib/python2.2/urllib2.py", line 809, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error (-3, 'Temporary failure in name
resolution')>

Volker.
Comment 3 Jef Spaleta 2004-01-29 09:49:45 EST
The proxy might be the problem....
Have to try to find people or other reports that can confirm proxy as
the problem.
Comment 4 Jef Spaleta 2004-01-29 10:12:19 EST

*** This bug has been marked as a duplicate of 102272 ***
Comment 5 Volker Meyer 2004-02-02 04:46:15 EST
I tried to reproduce the suggestions from bug 102272 comment #3
-
running up2date as root:
--
up2date -l

Fetching package list for channel: redhat-linux-i386-9...
########################################

Fetching package list for channel: fedora-core-1...

Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
There was some sort of I/O error: <urlopen error (-3, 'Temporary
failure in name resolution')>
---

Running with full pathname results in:
---
/usr/sbin/up2date -l

Fetching package list for channel: redhat-linux-i386-9...
########################################

Fetching package list for channel: fedora-core-1...

Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1165, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 745, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1028, in batchRun
    batch.run()
  File "up2dateBatch.py", line 57, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 117, in run
  File "rhnPackageInfo.py", line 316, in getAvailableAllArchPackageList
  File "rhnPackageInfo.py", line 156, in availablePackageList
  File "rpcServer.py", line 111, in doCall
  File "repoDirector.py", line 26, in listPackages
  File "rpmSource.py", line 226, in listPackages
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
197, in lis
tPackages
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
257, in fe
tchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
98, in ope
n_resource
    return opener.open(request)
  File "/usr/lib/python2.2/urllib2.py", line 328, in open
    '_open', req)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.2/urllib2.py", line 482, in <lambda>
    lambda r, proxy=url, type=type, meth=self.proxy_open: \
  File "/usr/lib/python2.2/urllib2.py", line 489, in proxy_open
    if '@' in host:
TypeError: iterable argument required
---
Comment 6 Red Hat Bugzilla 2006-02-21 14:00:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.