Bug 1141549 - ABRT cannot report any detected kernel oops
Summary: ABRT cannot report any detected kernel oops
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1152239 (view as bug list)
Depends On:
Blocks: F21BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-09-14 15:43 UTC by Mikhail
Modified: 2016-12-01 00:47 UTC (History)
11 users (show)

Fixed In Version: gnome-abrt-1.0.0-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 16:39:07 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of problem (174.75 KB, application/octet-stream)
2014-09-14 15:43 UTC, Mikhail
no flags Details
oops-2014-10-12-23:26:10-714-0 (31.11 KB, application/x-gzip)
2014-10-13 16:09 UTC, Mikhail
no flags Details
journald-kernel.txt (681.50 KB, text/plain)
2014-10-14 01:09 UTC, Mikhail
no flags Details

Description Mikhail 2014-09-14 15:43:19 UTC
Created attachment 937343 [details]
screenshot of problem

Description of problem:
--- Running report_uReport ---
Server responded with an error: 'Invalid JSON file'
reporter-ureport failed with exit code 1
('report_uReport' exited with 1)

--- Running report_EmergencyAnalysis ---
Compressing data
Sending /var/tmp/oops-2014-09-14-21:39:14-724-0.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/
Successfully sent /var/tmp/oops-2014-09-14-21:39:14-724-0.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/

Comment 1 Mikhail 2014-10-13 15:40:08 UTC
Problem still not fixed :(

Comment 2 Jakub Filak 2014-10-13 15:50:15 UTC
(In reply to Mikhail from comment #1)
> Problem still not fixed :(

Unfortunately, the uploaded dump directory has been removed by garbage collection. Could you please attach the dump directory to this bug report?

Comment 3 Mikhail 2014-10-13 16:09:00 UTC
Created attachment 946483 [details]
oops-2014-10-12-23:26:10-714-0

Comment 4 Jakub Filak 2014-10-13 21:41:17 UTC
Thank you! 'backtrace' file contains some invalid characters but 'dmesg' file is OK, thus I blame abrt-dump-journal-oops from adding these invalid characters.

Please run the following command and attach the resulting file journald-kernel.txt to this bug report:

$ sudo journalctl -o cat SYSLOG_IDENTIFIER=kernel > journald-kernel.txt

Comment 5 Jakub Filak 2014-10-13 21:42:48 UTC
*** Bug 1152239 has been marked as a duplicate of this bug. ***

Comment 6 Jakub Filak 2014-10-13 22:46:01 UTC
Mikhail, I don't need journald-kernel.txt file, I made same error as here: https://bugzilla.gnome.org/show_bug.cgi?id=709290 https://mail.gnome.org/archives/commits-list/2013-October/msg07813.html

Comment 7 Mikhail 2014-10-14 01:09:30 UTC
Created attachment 946637 [details]
journald-kernel.txt

Comment 8 Jakub Filak 2014-10-14 01:31:33 UTC
I've opened upstream pull request for this bug: https://github.com/abrt/abrt/pull/863

Comment 9 Fedora Blocker Bugs Application 2014-10-14 12:17:22 UTC
Proposed as a Freeze Exception for 21-beta by Fedora user jfilak using the blocker tracking app because:

 If this bug is not fixed users of Live CD will not be able to report any Kernel oops.

Comment 10 Fedora Update System 2014-10-14 12:21:59 UTC
gnome-abrt-1.0.0-1.fc21,abrt-2.3.0-2.fc21,libreport-2.3.0-2.fc21,satyr-0.15-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-abrt-1.0.0-1.fc21,abrt-2.3.0-2.fc21,libreport-2.3.0-2.fc21,satyr-0.15-1.fc21

Comment 11 Mikhail 2014-10-14 16:03:04 UTC
Please, look also that happens here https://bugzilla.redhat.com/show_bug.cgi?id=1152663

Comment 12 Adam Williamson 2014-10-15 16:44:13 UTC
Discussed at 2014-10-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-15/f21-blocker-review.2014-10-15-16.04.log.txt . Accepted as a freeze exception - problem reporting is significant, and this is one many people are running into. It affects the live images so cannot be fully fixed with an update.

Comment 13 Fedora Update System 2014-10-16 01:59:34 UTC
Package gnome-abrt-1.0.0-1.fc21, abrt-2.3.0-2.fc21, libreport-2.3.0-2.fc21, satyr-0.15-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-1.0.0-1.fc21 abrt-2.3.0-2.fc21 libreport-2.3.0-2.fc21 satyr-0.15-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12856/gnome-abrt-1.0.0-1.fc21,abrt-2.3.0-2.fc21,libreport-2.3.0-2.fc21,satyr-0.15-1.fc21
then log in and leave karma (feedback).

Comment 14 Jakub Filak 2014-10-16 06:17:38 UTC
The already detected kernel oopses will not be reportable with the updated packages. If you want to report them, you need first to delete them all and then re-detect them:

# delete the detected oopses
$ sudo rm -rf /var/tmp/abrt/oops*

# stop the service
$ sudo systemctl stop abrt-oops

# remove the state file if exists
$ sudo rm -f /var/lib/abrt/abrt-dump-journal-oops.state

# extract oopses from entire journal
$ sudo abrt-dump-journal-oops -Dx

# save cursor to the last kernel message
$ sudo journalctl -n 1 -o verbose SYSLOG_IDENTIFIER=kernel | sed -n 's/^.*\[\(.*\)\].*$/\1/p' | sudo tee /var/lib/abrt/abrt-dump-journal-oops.state

# start the service
$ sudo systemctl start abrt-oops

Comment 15 Fedora Update System 2014-10-20 16:39:07 UTC
gnome-abrt-1.0.0-1.fc21, abrt-2.3.0-2.fc21, libreport-2.3.0-2.fc21, satyr-0.15-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.