Bug 114166 - cpuspeed fails to start without modprobing additional modules
cpuspeed fails to start without modprobing additional modules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 10:43 EST by Joe Ammond
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-07 12:28:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to /etc/init.d/cpuspeed (391 bytes, patch)
2004-01-23 10:44 EST, Joe Ammond
no flags Details | Diff

  None (edit)
Description Joe Ammond 2004-01-23 10:43:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Hardware: Dell Latitide D600
Kernel: kernel-2.6.1-1.53

On my Dell Latitude D600 laptop, cpuspeed fails to start even
with the speedstep-centrino module in the DRIVER= line in
/etc/cpuspeed.conf.  The cpufreq_userspace module needs to
be loaded as well for cpuspeed to function.  As a work-around,
I modified /etc/init.d/cpuspeed to treat the DRIVER= line
from cpuspeed.conf as a list of modules, and modprobe each
accordingly.  Another work-around is to modprobe cpufreq_userspace
first, then re-run /etc/init.d/cpuspeed manually.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-9.1.115

How reproducible:
Always

Steps to Reproduce:
1. Power on the machine, cpuspeed fails to start due because
cpufreq_userpsace isn't present.


Additional info:
Comment 1 Joe Ammond 2004-01-23 10:44:41 EST
Created attachment 97211 [details]
Patch to /etc/init.d/cpuspeed
Comment 2 Michael McCabe 2004-02-06 08:03:47 EST
I've got the same problem right now.
Comment 3 Joe Ammond 2004-02-06 18:06:18 EST
From rpm -q --changelog kernel :

* Tue Jan 27 2004 Dave Jones <davej@redhat.com>

- Update to 2.6.2-rc2-bk1
- Set default CPUFREQ governor to userspace instead of performance.

This eliminates the problem I had with cpuspeed starting.  Given
that, I'd consider this closed.

Note You need to log in before you can comment on or make changes to this bug.