Bug 1141669 - remove ExclusiveArch for Fedora builds
Summary: remove ExclusiveArch for Fedora builds
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: vdsm
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yaniv Bronhaim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: infra
Depends On:
Blocks: ARMTracker ZedoraTracker F-ExcludeArch-ppc64le, PPC64LETracker 1057724
TreeView+ depends on / blocked
 
Reported: 2014-09-15 07:56 UTC by Dan Horák
Modified: 2015-12-02 16:16 UTC (History)
6 users (show)

Fixed In Version: vdsm v4.16.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 03:48:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 33368 master MERGED spec: allow all archs in Fedora Never
oVirt gerrit 33404 ovirt-3.5 MERGED spec: allow all archs in Fedora Never
oVirt gerrit 33711 master MERGED Moving python_sitearch to python_sitelib Never
oVirt gerrit 33738 ovirt-3.5 MERGED Moving python_sitearch to python_sitelib Never

Description Dan Horák 2014-09-15 07:56:11 UTC
You should remove the recently added ExclusiveArch tag from Fedora builds, see
http://fedoraproject.org/wiki/Packaging:Guidelines#Architecture_Support

If there is a problem on a secondary arch, please contact the respective team before disabling the arch completely.


Version-Release number of selected component (if applicable):
vdsm-4.16.4-0.fc22

Comment 1 Allon Mureinik 2014-09-28 13:57:55 UTC
Both patches seem to be merged.
Is anything else missing here, or can this be moved to MODIFIED?

Comment 2 Dan Kenigsberg 2014-09-29 10:24:30 UTC
We still have troubles building for ARM. Douglas, would you post here your rpmdiff issue?

Comment 3 Dan Horák 2014-09-29 10:35:39 UTC
If there are issues, please let us know and we (the secondary arch teams) can work with you on resolving them.

Comment 4 Douglas Schilling Landgraf 2014-09-29 13:55:48 UTC
[fedora@oier vdsm]$ fedpkg --dist f20 scratch-build --srpm /home/fedora/rpmbuild/SRPMS/vdsm-4.16.5-5.gitb16b036.fc20.src.rpm
[====================================] 100% 00:00:08   1.52 MiB 181.34 KiB/sec
Building vdsm-4.16.5-5.gitb16b036.fc20.src.rpm for f20-candidate
Created task: 7714471
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=7714471
Watching tasks (this may be safely interrupted)...
7714471 build (f20-candidate, vdsm-4.16.5-5.gitb16b036.fc20.src.rpm): open (arm02-builder22.arm.fedoraproject.org)
  7714472 buildArch (vdsm-4.16.5-5.gitb16b036.fc20.src.rpm, armv7hl): open (arm02-builder05.arm.fedoraproject.org)
  7714474 buildArch (vdsm-4.16.5-5.gitb16b036.fc20.src.rpm, i686): open (buildhw-08.phx2.fedoraproject.org)
  7714473 buildArch (vdsm-4.16.5-5.gitb16b036.fc20.src.rpm, x86_64): open (buildvm-13.phx2.fedoraproject.org)
  7714473 buildArch (vdsm-4.16.5-5.gitb16b036.fc20.src.rpm, x86_64): open (buildvm-13.phx2.fedoraproject.org) -> closed
  0 free  3 open  1 done  0 failed
  7714474 buildArch (vdsm-4.16.5-5.gitb16b036.fc20.src.rpm, i686): open (buildhw-08.phx2.fedoraproject.org) -> closed
  0 free  2 open  2 done  0 failed
  7714472 buildArch (vdsm-4.16.5-5.gitb16b036.fc20.src.rpm, armv7hl): open (arm02-builder05.arm.fedoraproject.org) -> closed
  0 free  1 open  3 done  0 failed
7714471 build (f20-candidate, vdsm-4.16.5-5.gitb16b036.fc20.src.rpm): open (arm02-builder22.arm.fedoraproject.org) -> FAILED: BuildError: mismatch when analyzing vdsm-python-4.16.5-5.gitb16b036.fc20.noarch.rpm, rpmdiff output was:
removed     /usr/lib/python2.7/site-packages/vdsm
removed     /usr/lib/python2.7/site-packages/vdsm/SecureXMLRPCServer.py
removed     /usr/lib/python2.7/site-packages/vdsm/SecureXMLRPCServer.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/SecureXMLRPCServer.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/__init__.py
removed     /usr/lib/python2.7/site-packages/vdsm/__init__.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/__init__.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/compat.py
removed     /usr/lib/python2.7/site-packages/vdsm/compat.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/compat.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/config.py
removed     /usr/lib/python2.7/site-packages/vdsm/config.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/config.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/constants.py
removed     /usr/lib/python2.7/site-packages/vdsm/constants.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/constants.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/define.py
removed     /usr/lib/python2.7/site-packages/vdsm/define.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/define.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/exception.py
removed     /usr/lib/python2.7/site-packages/vdsm/exception.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/exception.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/ipwrapper.py
removed     /usr/lib/python2.7/site-packages/vdsm/ipwrapper.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/ipwrapper.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/libvirtconnection.py
removed     /usr/lib/python2.7/site-packages/vdsm/libvirtconnection.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/libvirtconnection.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/netconfpersistence.py
removed     /usr/lib/python2.7/site-packages/vdsm/netconfpersistence.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/netconfpersistence.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/netinfo.py
removed     /usr/lib/python2.7/site-packages/vdsm/netinfo.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/netinfo.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/netlink.py
removed     /usr/lib/python2.7/site-packages/vdsm/netlink.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/netlink.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/profile.py
removed     /usr/lib/python2.7/site-packages/vdsm/profile.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/profile.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/qemuimg.py
removed     /usr/lib/python2.7/site-packages/vdsm/qemuimg.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/qemuimg.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/sslutils.py
removed     /usr/lib/python2.7/site-packages/vdsm/sslutils.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/sslutils.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool
removed     /usr/lib/python2.7/site-packages/vdsm/tool/__init__.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/__init__.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/__init__.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurator.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurator.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurator.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/__init__.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/__init__.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/__init__.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/certificates.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/certificates.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/certificates.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/configfile.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/configfile.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/configfile.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/libvirt.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/libvirt.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/libvirt.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/sanlock.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/sanlock.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/configurators/sanlock.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/dummybr.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/dummybr.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/dummybr.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/nwfilter.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/nwfilter.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/nwfilter.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/passwd.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/passwd.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/passwd.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/restore_nets.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/restore_nets.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/restore_nets.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/seboolsetup.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/seboolsetup.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/seboolsetup.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/service.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/service.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/service.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/transient.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/transient.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/transient.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/unified_persistence.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/unified_persistence.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/unified_persistence.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/upgrade.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/upgrade.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/upgrade.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/upgrade_300_networks.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/upgrade_300_networks.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/upgrade_300_networks.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/validate_ovirt_certs.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/validate_ovirt_certs.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/validate_ovirt_certs.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/tool/vdsm-id.py
removed     /usr/lib/python2.7/site-packages/vdsm/tool/vdsm-id.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/tool/vdsm-id.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/utils.py
removed     /usr/lib/python2.7/site-packages/vdsm/utils.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/utils.pyo
removed     /usr/lib/python2.7/site-packages/vdsm/vdscli.py
removed     /usr/lib/python2.7/site-packages/vdsm/vdscli.pyc
removed     /usr/lib/python2.7/site-packages/vdsm/vdscli.pyo
added       /usr/lib64/python2.7/site-packages/vdsm
added       /usr/lib64/python2.7/site-packages/vdsm/SecureXMLRPCServer.py
added       /usr/lib64/python2.7/site-packages/vdsm/SecureXMLRPCServer.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/SecureXMLRPCServer.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/__init__.py
added       /usr/lib64/python2.7/site-packages/vdsm/__init__.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/__init__.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/compat.py
added       /usr/lib64/python2.7/site-packages/vdsm/compat.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/compat.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/config.py
added       /usr/lib64/python2.7/site-packages/vdsm/config.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/config.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/constants.py
added       /usr/lib64/python2.7/site-packages/vdsm/constants.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/constants.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/define.py
added       /usr/lib64/python2.7/site-packages/vdsm/define.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/define.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/exception.py
added       /usr/lib64/python2.7/site-packages/vdsm/exception.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/exception.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/ipwrapper.py
added       /usr/lib64/python2.7/site-packages/vdsm/ipwrapper.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/ipwrapper.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/libvirtconnection.py
added       /usr/lib64/python2.7/site-packages/vdsm/libvirtconnection.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/libvirtconnection.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/netconfpersistence.py
added       /usr/lib64/python2.7/site-packages/vdsm/netconfpersistence.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/netconfpersistence.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/netinfo.py
added       /usr/lib64/python2.7/site-packages/vdsm/netinfo.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/netinfo.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/netlink.py
added       /usr/lib64/python2.7/site-packages/vdsm/netlink.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/netlink.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/profile.py
added       /usr/lib64/python2.7/site-packages/vdsm/profile.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/profile.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/qemuimg.py
added       /usr/lib64/python2.7/site-packages/vdsm/qemuimg.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/qemuimg.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/sslutils.py
added       /usr/lib64/python2.7/site-packages/vdsm/sslutils.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/sslutils.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool
added       /usr/lib64/python2.7/site-packages/vdsm/tool/__init__.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/__init__.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/__init__.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurator.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurator.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurator.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/__init__.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/__init__.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/__init__.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/certificates.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/certificates.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/certificates.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/configfile.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/configfile.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/configfile.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/libvirt.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/libvirt.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/libvirt.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/sanlock.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/sanlock.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/configurators/sanlock.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/dummybr.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/dummybr.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/dummybr.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/nwfilter.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/nwfilter.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/nwfilter.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/passwd.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/passwd.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/passwd.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/restore_nets.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/restore_nets.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/restore_nets.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/seboolsetup.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/seboolsetup.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/seboolsetup.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/service.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/service.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/service.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/transient.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/transient.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/transient.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/unified_persistence.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/unified_persistence.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/unified_persistence.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/upgrade.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/upgrade.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/upgrade.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/upgrade_300_networks.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/upgrade_300_networks.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/upgrade_300_networks.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/validate_ovirt_certs.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/validate_ovirt_certs.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/validate_ovirt_certs.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/tool/vdsm-id.py
added       /usr/lib64/python2.7/site-packages/vdsm/tool/vdsm-id.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/tool/vdsm-id.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/utils.py
added       /usr/lib64/python2.7/site-packages/vdsm/utils.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/utils.pyo
added       /usr/lib64/python2.7/site-packages/vdsm/vdscli.py
added       /usr/lib64/python2.7/site-packages/vdsm/vdscli.pyc
added       /usr/lib64/python2.7/site-packages/vdsm/vdscli.pyo
  0 free  0 open  3 done  1 failed

Comment 5 Dan Horák 2014-09-30 10:47:51 UTC
At first look either the python subpackage is not noarch or it uses %python_sitearch instead of %python_sitelib as installation path.

Comment 6 Dan Horák 2014-09-30 11:05:00 UTC
IMO all you need is to drop the noarch for the python subpackage, it was done so also in the past (eg. http://koji.fedoraproject.org/koji/buildinfo?buildID=546565).

scratch build with
diff --git a/vdsm.spec b/vdsm.spec
index d740f91..8a6b9aa 100644
--- a/vdsm.spec
+++ b/vdsm.spec
@@ -361,7 +361,6 @@ Requires:       %{name}-python-zombiereaper = %{version}-%{release}
 Requires:       python-cpopen >= 1.2.3-5
 Requires:       m2crypto
 Requires:       python-ioprocess >= 0.12
-BuildArch:      noarch
 
 %description python
 Shared libraries between the various VDSM packages.

is http://koji.fedoraproject.org/koji/taskinfo?taskID=7728775

Comment 7 Douglas Schilling Landgraf 2014-10-01 19:45:21 UTC
(In reply to Dan Horák from comment #6)
> IMO all you need is to drop the noarch for the python subpackage, it was
> done so also in the past (eg.
> http://koji.fedoraproject.org/koji/buildinfo?buildID=546565).
> 
> scratch build with
> diff --git a/vdsm.spec b/vdsm.spec
> index d740f91..8a6b9aa 100644
> --- a/vdsm.spec
> +++ b/vdsm.spec
> @@ -361,7 +361,6 @@ Requires:       %{name}-python-zombiereaper =
> %{version}-%{release}
>  Requires:       python-cpopen >= 1.2.3-5
>  Requires:       m2crypto
>  Requires:       python-ioprocess >= 0.12
> -BuildArch:      noarch
>  
>  %description python
>  Shared libraries between the various VDSM packages.
> 
> is http://koji.fedoraproject.org/koji/taskinfo?taskID=7728775

Thanks Dan Horák, removing noarch made the trick. Although, I am curious why a noarch python package macro makes hard to koji arm.

Comment 8 Dan Horák 2014-10-01 20:00:29 UTC
(In reply to Douglas Schilling Landgraf from comment #7)
> (In reply to Dan Horák from comment #6)
> > IMO all you need is to drop the noarch for the python subpackage, it was
> > done so also in the past (eg.
> > http://koji.fedoraproject.org/koji/buildinfo?buildID=546565).
> > 
> > scratch build with
> > diff --git a/vdsm.spec b/vdsm.spec
> > index d740f91..8a6b9aa 100644
> > --- a/vdsm.spec
> > +++ b/vdsm.spec
> > @@ -361,7 +361,6 @@ Requires:       %{name}-python-zombiereaper =
> > %{version}-%{release}
> >  Requires:       python-cpopen >= 1.2.3-5
> >  Requires:       m2crypto
> >  Requires:       python-ioprocess >= 0.12
> > -BuildArch:      noarch
> >  
> >  %description python
> >  Shared libraries between the various VDSM packages.
> > 
> > is http://koji.fedoraproject.org/koji/taskinfo?taskID=7728775
> 
> Thanks Dan Horák, removing noarch made the trick. Although, I am curious why
> a noarch python package macro makes hard to koji arm.

It is because the python package is not noarch, it uses %python_sitearch as install dir, which expands to /usr/lib/python... on 32-bit arches and /usr/lib64/python... on 64-bit arches. So the same problem as with arm was with i686 versus x86_64.

If the python stuff is really noarch (means the *.py files are the same on all arches, no arch dependent file paths in them, etc), then it should be made to install into %python_sitelib.

Comment 9 Douglas Schilling Landgraf 2014-10-02 01:32:56 UTC
(In reply to Dan Horák from comment #8)
> (In reply to Douglas Schilling Landgraf from comment #7)
> > (In reply to Dan Horák from comment #6)
> > > IMO all you need is to drop the noarch for the python subpackage, it was
> > > done so also in the past (eg.
> > > http://koji.fedoraproject.org/koji/buildinfo?buildID=546565).
> > > 
> > > scratch build with
> > > diff --git a/vdsm.spec b/vdsm.spec
> > > index d740f91..8a6b9aa 100644
> > > --- a/vdsm.spec
> > > +++ b/vdsm.spec
> > > @@ -361,7 +361,6 @@ Requires:       %{name}-python-zombiereaper =
> > > %{version}-%{release}
> > >  Requires:       python-cpopen >= 1.2.3-5
> > >  Requires:       m2crypto
> > >  Requires:       python-ioprocess >= 0.12
> > > -BuildArch:      noarch
> > >  
> > >  %description python
> > >  Shared libraries between the various VDSM packages.
> > > 
> > > is http://koji.fedoraproject.org/koji/taskinfo?taskID=7728775
> > 
> > Thanks Dan Horák, removing noarch made the trick. Although, I am curious why
> > a noarch python package macro makes hard to koji arm.
> 
> It is because the python package is not noarch, it uses %python_sitearch as
> install dir, which expands to /usr/lib/python... on 32-bit arches and
> /usr/lib64/python... on 64-bit arches. So the same problem as with arm was
> with i686 versus x86_64.
> 
> If the python stuff is really noarch (means the *.py files are the same on
> all arches, no arch dependent file paths in them, etc), then it should be
> made to install into %python_sitelib.

Thanks Dan Horák, make sense. The .py should be the same to all platforms right Dan Kenigsberg ?

Comment 10 Dan Kenigsberg 2014-10-02 09:21:25 UTC
Right. http://gerrit.ovirt.org/31071 should have moved everything to %python_sitelib.

Comment 11 Fedora End Of Life 2015-11-04 16:03:30 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 12 Fedora End Of Life 2015-12-02 03:48:52 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.