Bug 114169 - 'Select a Workflow' in item creattion useless
'Select a Workflow' in item creattion useless
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
Jon Orris
:
Depends On:
Blocks: 106481
  Show dependency treegraph
 
Reported: 2004-01-23 11:04 EST by Jon Orris
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 16:54:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2004-01-23 11:04:12 EST
Description of problem:
@39671/Postgres

If the SWA attempts to create an Item, a 'Select a Workflow' label
will show up. If the SWA creates the Item, the sytem will refuse,
saying that the Workflow parameter is required.

The problem is that there is no workflow select widget, just a label,
making it impossible to fulfill the requirements to submit the form.
Comment 1 Scott Seago 2004-01-23 11:09:58 EST
Actually, it's not useless -- It's just missing the proper "you don't
belong to any workflows" label when there are none to choose from. It
_may_ be that the proper thing to do here is that for users with the
Item Administration function we want to show all workflows. We've got
to be careful with that, though, because once the item is assigned a
workflow, the SWA won't be able to edit anyway (without stopping the
workflow), since you can't edit an item in a workflow without locking
it, and you can't lock it without being assigned it.
Comment 2 Scott Seago 2004-01-23 13:26:54 EST
ok, so I think I will, in the case where an admin (or anyone with
apply alternate workflow permissions) has no workflows to choose from,
we'll hide the entire widget, and apply the default workflow insead.
So here's the behavior:
1) if user has apply alternate workflow permission and belongs to one
one more workflows, the user gets the form (with >=1 choice) and it's
required
2) otherwise apply the default.
Comment 3 Scott Seago 2004-01-23 15:33:48 EST
I've applied the fix as described above. Notice that even with the
fix, the admin in question will be able to create the item, but he
won't be able to edit it unless the admin gets added to the workflow
_or_ the workflow is stopped, since an item in an active workflow
can't be edited without a locked task.

Note You need to log in before you can comment on or make changes to this bug.