Bug 114174 - Kickstart install started over serial console does not append "console=ttyS0" to elilo.conf
Kickstart install started over serial console does not append "console=ttyS0"...
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
ia64 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
HP requests FIX for U4
:
Depends On:
Blocks: 116726
  Show dependency treegraph
 
Reported: 2004-01-23 11:43 EST by Glen A. Foster
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 20:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (2.41 KB, text/plain)
2004-03-10 11:23 EST, James McDermott
no flags Details

  None (edit)
Description Glen A. Foster 2004-01-23 11:43:22 EST
Description of problem: When AS 2.1 update 3 is installed via
kickstart and the whole thing is initiated over serial console, the
resulting install configures /dev/ttyS0 in /etc/securetty and there's
a getty configured for /dev/ttyS0 in /etc/inittab -- but elilo.conf
does not have the line

    append="console=ttyS0"

... however, if there's a SCSI CD-RW drive in the box, there IS the
appropriate append for "hda=ide-scsi" present.

Version-Release number of selected component (if applicable):
RHEL 2.1 AS update 3

How reproducible: 100%

Steps to Reproduce:
1. start up kickstart install (NFS path to script) over serial console

linux ks=nfs:serverIP:/path/to/ks.cfg console=ttyS0
Comment 1 Glen A. Foster 2004-01-23 12:16:08 EST
Sorry, Tim -- already known.

*** This bug has been marked as a duplicate of 112776 ***
Comment 2 Glen A. Foster 2004-01-23 12:34:22 EST
Aaaaarg!  Wrong bug closed.  Bad Glen!  Bad dog!
Comment 3 Jeremy Katz 2004-02-12 17:03:33 EST
I remember this working for me... did this just break in U3 (since I
definitely didn't change any code in this area)?
Comment 4 Glen A. Foster 2004-03-01 15:58:55 EST
I'm (finally) getting around to trying this with AS2.1 Update 2...
just so I know if I'm doing this correctly, I start up the kickstart
with console=ttyS0 on the command line (e.g., there's nothing in the
kickstart script required to make this happen) and it's just supposed
to work, right?
Comment 5 Glen A. Foster 2004-03-01 17:02:59 EST
Same behavior with 2.1-update-2 -- I perform an everything install,
edit the kickstart config, reboot with "linux ks=nfs:IP:path
console=ttyS0".
Kickstart does indeed run but there's no console=ttyS0 in "elilo.conf".
Comment 6 Glen A. Foster 2004-03-01 17:37:10 EST
Same behavior with stock 2.1 Advanced Server.
Comment 7 Larry Troan 2004-03-07 12:18:45 EST
Glen, any special box to recreate this? 

SEG, Summer has an IPF workstation (zx2000?) in her office that you 
may be able to use. 
Comment 8 Larry Troan 2004-03-07 12:19:53 EST
ISSUE TRACKER 35444 OPENED AS SEV 1
Comment 9 Larry Troan 2004-03-07 12:25:24 EST
HP-IPF asks this me fixed for U4. Nominating for U5 MUSTFIX in case 
it doesn't make U2.
Comment 10 Glen A. Foster 2004-03-08 10:06:09 EST
I can recreate this problem reliably on a Longs Peak (rx2600).  It
shouldn't take anything special.
Comment 11 James McDermott 2004-03-08 18:45:49 EST
Glen, I just ran an install on the aforementioned zx2000 with AS2.1 U3
and the line made it to elilo.conf. Can you please try with u3. 
Comment 12 Glen A. Foster 2004-03-09 13:17:28 EST
Hi, James - long time no hear/see!

Actually, I mentioned in the initial problem report that I get this
behavior EVERY time I do a kickstart install on IPF.  And later on in
the defect report, I confirmed it appears it's always been that way
for RHEL 2.1, RHEL 2.1 update 2, and RHEL 2.1 update 3.

I get the serial console lines when I do a plain install.  This defect
report is specifically for a "kickstart" install -- and I select the
"Everything" package set, in case it really matters.

Please tell Tish I said "how-dee" next time you remember it, OK?
Comment 13 James McDermott 2004-03-09 13:41:01 EST
Ok, going to attempt a kickstart version today to replicate. And Ill
make sure to tell her:)
Comment 14 James McDermott 2004-03-10 11:15:56 EST
So I ran the kickstart and it propogated the line to elilo.conf. I am
attaching the ks.cfg I used with names changed to protect the
innocent. Any chance you could throw yours up here so I can give it a
hack. Also the one possible difference I noted was that I set the
speed for the console at the command line when I ran it: 

linux text console=ttyS0,9600n8 ks=nfs:nfsserver.com:/kickstart/ks.cfg
Comment 15 James McDermott 2004-03-10 11:23:15 EST
Created attachment 98428 [details]
kickstart file

This file coupled with the linux:
linux text console=ttyS0,9600n8 ks=nfs:nfsserver.com/kickstart/anaconda-ks.cfg 

seemed to propogate changes where neccessary to ensure the console line works
after install.
Comment 16 Glen A. Foster 2004-03-13 11:25:51 EST
The hardware-independent portions of the kickstart script attached in
comment #15 isn't that different from what I've got.  But I _am_ using
the kickstart script from what anaconda drops, adding only the "nfs
--server" line, adding "text", and adding "reboot" so that I can
completely automate the kickstart install.

Differences I see in what anaconda makes and the above ks script:

Johns: bootloader
Mine: bootloader --append hda=ide-scsi console=ttyS0
Mine: text
Mine: reboot

Again, the ks script I'm using was generated by anaconda and when I
use it, I get no setup for "console=ttyS0".

So, is it the "text" path, does "reboot" cause the setup to not take
place, or does the different "bootloader" clause cause the problem?
Comment 17 Glen A. Foster 2004-03-14 19:25:34 EST
Johns?  Sorry, I mean James' ... and this is entirely reproducible,
using the kickstart script created by anaconda.
Comment 18 Glen A. Foster 2004-03-24 10:01:54 EST
I can still reproduce this AT WILL on both RHEL3 update 2 and RHAS 2.1
update 4.  Is this going to be fixed?  Enterprise customers need to
have the ability to install systems via kickstart and know that if
it's invoked over a serial console that the system configuration will
be right at post-install time.
Comment 19 James McDermott 2004-03-24 10:21:52 EST
Yeah, It appears the bug(s) are related to the kickstart file and also
the gui kickstart configurator. The Gui tool adds options which dont
work, and the kickstart file generated during install appears to do
strange things. It appears you can workaround this by writing your own
like the one I attached above, but the other two parts appear to be bugs.
Comment 20 Jeremy Katz 2004-03-27 15:07:07 EST
Note that the only way to get all of the serial console stuff always
set up right (and the way that I've always instructed people to do it)
is to do the install as a serial install passing all of the console
options during the install.   You can add some quoting and it will do
some of the things, but it's not guaranteed to do everything (only the
kernel argument side)
Comment 21 Glen A. Foster 2004-03-29 10:13:57 EST
But... I *am* running the kickstart over serial console. :)
I suspect the problem has something to do with the bootloader line.  I
looked at the docs but I can't really tell what's going on.  I'm using
the kickstart script that anaconda generates and all I'm adding are
the lines "text", "reboot", and some sort of network/hard-drive
install reference so kickstart knows where to look for the distro (and
the latter lines work because the package selection/installation stuff
is fine) -- it's just that when run over a serial console, the
kickstart script generated by anaconda doesn't configure console=ttyS0
properly.

Is this enough for you to hunt down and kill this?  This problem is
seen on both RHEL 2.1 and RHEL 3.
Comment 23 Jeremy Katz 2004-06-09 16:48:58 EDT
If you quote the bootloader arguments as

bootloader --append="hda=ide-scsi console=ttyS0"

does it work?  Looks like it should
Comment 24 Glen A. Foster 2004-06-09 19:54:26 EDT
Yes, it works when I force it myself.  It would be EvenCooler(tm) if
anaconda could/would do that for the customer.
Comment 25 Jeremy Katz 2004-06-09 20:26:03 EDT
Okay, added bits so that we quote appends in CVS which should take
care of this.
Comment 26 Glen A. Foster 2004-10-31 11:06:07 EST
Validated the changes work correctly in RHEL2.1 update 6 beta. Thanks!

Note You need to log in before you can comment on or make changes to this bug.