Bug 1141902 - Rubygem-Staypuft: in UI after clicking on the "Done" button in "Configure Networks" the host(s) should discontinue be selected.
Summary: Rubygem-Staypuft: in UI after clicking on the "Done" button in "Configure Ne...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z2
: Installer
Assignee: Jason E. Rist
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-15 17:20 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:02 UTC (History)
2 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-09-15 17:20:50 UTC
Rubygem-Staypuft:  in UI after clicking on the "Done" button in "Configure Networks" the host(s) should discontinue be selected.


Environment:
rhel-osp-installer-0.3.4-3.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.23-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch


Steps to reproduce:
1. Install rhel-osp-installer.
2. Configure a deployment of any kind and assign a couple of hosts to it.
3. In the deployment configuration page: go to Hosts-> Assigned. Select a host (or several) and click on the "Configure Networks" button. 
4. Once the desired network configuration is completed, click on done.


Result:
The selected host (or several hosts) is still selected, so it needs to be unselected prior to selecting other hosts.

Expected result:
The selection should be cleared once the user completed the "Configure Network" function.

Comment 1 Jason E. Rist 2014-10-02 02:05:00 UTC
https://github.com/theforeman/staypuft/pull/328

Comment 4 Alexander Chuzhoy 2014-10-07 14:33:03 UTC
Verified: rhel-osp-installer-0.4.1-2.el6ost.noarch


This works now - the selection is cleared after configuring the network of the host(s).

Comment 6 errata-xmlrpc 2014-11-04 17:02:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.