Bug 114191 - hpijs driver doesn't handle paper sizes correctly like ljet4 driver
hpijs driver doesn't handle paper sizes correctly like ljet4 driver
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: hpijs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 15:15 EST by Jonathan Kamens
Modified: 2008-05-06 19:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 19:57:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2004-01-23 15:15:07 EST
If I send a file to the ljet4 driver with this line at the top:

<< /PageSize [279 639]>> setpagedevice

The driver figures out the page size supported by the printer that is
closest to the specified page size and tells the printer to use that
page size automatically in the PCL output.

The hpijs driver doesn't do this.  In fact, it apparently doesn't even
set the paper size when I specify "-o PageSize=Env10" to the "lp"
command when printing through the hpijs driver.

Badness.
Comment 1 Tim Waugh 2004-01-28 06:24:51 EST
Reported upstream.

Could you put 'debug: 1' into /etc/foomatic/filter.conf and try again,
then check the /tmp/foomatic-rip.ps file?  Perhaps foomatic is
mangling the PageSize.
Comment 2 Jonathan Kamens 2004-01-28 08:30:30 EST
It's not foomatic.  I printed a test with a different paper size to
the ljet4 driver, which worked.  Then I switched to the hpijs driver
and it failed.  Then I switched back to the ljet4 driver *and printed
/tmp/foomatic-rip.ps from when I printed to the hpijs driver*, and
that file printed with the correct paper size.  So clearly when the
data gets to /tmp/foomatic-rip.ps it is still valid; I'm pretty
certain it's the hpijs driver which isn't handling paper sizes properly.

And I say that as the person who wrote the paper-size-handling code in
the ljet driver :-).
Comment 3 Tim Waugh 2004-01-29 10:18:03 EST
The upstream maintainer says that there is a known bug in PCL
generation for envelope sizes: it uses custom paper size instead of
unique envelope size.  Although it works fine for inkjets the
LaserJets don't like it.

Will be fixed in the next release apparently.
Comment 4 Vaclav "sHINOBI" Misek 2004-02-29 19:24:25 EST
I'm not sure, if it's the same bug, but I have similar problem with
printing A4 page. Printing stops at 260 mm (A4 page is approx. 300
mm). I have HP DeskJet 5550, and I'm using hpijs driver as well.
Comment 5 David W. Legg 2005-12-03 16:20:45 EST
I too get this problem on my HP Deskjet 1280 with A4 paper.
The print gets chopped at something like US Letter size (length).
Width seems ok.

Using Fedora Core 3, completely up to date as of 3/12/2005.
So it's been nearly a couple of years and this one is still hanging around
(if it is the same bug, that is.)

Got cups-1.1.22-0.rc1.8.7
and hpijs-1.6-2

I also tried lying about the paper sizes in the .ppd file to no avail.
And I downloaded the latest .ppd too.
Comment 6 David W. Legg 2005-12-12 10:37:20 EST
Correction, the incorrect size is somewhere between A4 and Letter size.

Also, when I build the latest HPLIP package 0.9.7, presumably that replaces the
hpijs-1.6.2 driver doesn't it. Well, the sizing problem is still there.

It is also there in Core 4 too.

BTW: The ppd file *is* set up to do A4, not Letter size!
Comment 7 Bug Zapper 2008-04-03 11:31:42 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 8 Bug Zapper 2008-05-06 19:57:47 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.