Bug 1141945 - Rubygem-Staypuft: in UI under the "Network Configuration" page: the roles that don't need to be under the default network, should appear under "Available Network Traffic Types".
Summary: Rubygem-Staypuft: in UI under the "Network Configuration" page: the roles th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z2
: Installer
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-15 20:23 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:02 UTC (History)
3 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.5-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-09-15 20:23:31 UTC
Rubygem-Staypuft:  in UI under the "Network Configuration" page: the roles that don't need to be under the default network, should appear under "Available Network Traffic Types".

Environment:
rhel-osp-installer-0.3.4-3.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.23-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch


Steps to reproduce:
1. install rhel-osp-installer.
2. Configure a deployment of any type and get to the "Network Configuration" page.


Result:
All the network roles appear under the "default" subnet.


Expected results:

Some network roles need to be separated from the default subnet and as such they should appear under the "Available Network Traffic Types" field.

Comment 1 Scott Seago 2014-09-29 17:34:03 UTC
Hmm. I think the title of this bug is misleading. In reality, *none* of the networks types need to be on the default network. I think the intent here is to remove those network types that *must not* be on the default network.

Also, to clarify, at this point is that only the tenant and external networks? API networks, storage, etc. can all be on the default?

Comment 2 Scott Seago 2014-10-08 14:57:29 UTC
Resolved by https://github.com/theforeman/staypuft/pull/333

Comment 5 Alexander Chuzhoy 2014-10-20 16:49:15 UTC
Verified:

openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.6-1.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch


Bearing in mind comment #1:
verified that roles tenant and external in fact appear under the "Available Network Traffic Types" field.

Comment 7 Mike Burns 2014-10-24 13:35:33 UTC
doc text covered by another bz.

Comment 9 errata-xmlrpc 2014-11-04 17:02:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.