Bug 1142128 - python-pylons: Build for EPEL 7
Summary: python-pylons: Build for EPEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pylons
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Kim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1163577 1175527
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-16 08:20 UTC by Alejandro Alvarez
Modified: 2015-06-18 18:33 UTC (History)
4 users (show)

Fixed In Version: python-pylons-1.0.1-2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-18 18:33:59 UTC


Attachments (Terms of Use)

Description Alejandro Alvarez 2014-09-16 08:20:33 UTC
Hi,

Could you please provide an epel7 build of python-pylons? It is a dependency of fts-rest, which I would like to package for epel7.

Regards.

Comment 1 Alejandro Alvarez 2014-09-26 08:56:18 UTC
Ping?

Comment 2 Kim 2014-12-22 16:08:26 UTC
Using python-pylons-1.0.1-1.fc19.src.rpm, pylons appears to function after fixing the dependency of MarkupSafe to be >=0.11

requires.txt
MarkupSafe>=0.11

Comment 3 Kim 2015-04-24 21:38:05 UTC
It appears after reviewing the changes in MarkupSafe, it is safe to use the lower version number of MarkupSafe.

It looks to me that no changes from 0.11 to 0.15 took place that change the behavior of markupsafe. The following is a review of all the changes that took place in MarkupSafe.

https://github.com/mitsuhiko/markupsafe/commits/master

414929fec00bab788181115fe6a76252985aa6c8 Raised version number

My Comment -> This is a simple version number change from 0.10 to 0.11

0dff0a079d55abd0e441d55693b605ff6d69c50a Changed PyUnicodeObject struct access into official CPython Macro use…

…s. The macros evaluate to the same code, but this makes it possible to use with PyPy.

My Comment -> Support for PyPy

71693a29735082f78fe84d7311f5e33aed69ef8b added changelog, raise to 0.12

My Comment -> This is a simple version number change from 0.11 to 0.12

6b676ac6ccc6ca9fc0006d758d4eb98ee437061e master is 0.13-dev 

My Comment -> This is a simple version number change from 0.12 to 0.13

4964e7780911d32119ddfbef26c2ba20e5bc80d5 Workaround for Python Issue7511 (setup failing on Win 64). 

My Comment -> This appears to be a fix for only Windows 64 builds

796b2ea5d4bb264a3fc291b4cf507e4953a98c69 Workaround for Issue7511 did not run under Python 3.

My Comment -> Windows 64 build issue involving Python 3

178f60584374bfc10ac257c74bcc2c36dffff7c9 Added basic benchmarks

My Comment -> Tests being added to benchmark performance.

2f39e0e9036e4c6afd9c2c05dee355a81bd421ec  Merge pull request #3 from Cito/master

Small fix for installation problems under Win 64bit

My Comment -> This is a build issue on Windows 64 bit again.

4e69e867abb29c30442b4f40e4018fead43f5684 Merge branch 'master' of github.com:mitsuhiko/markupsafe 

My Comment -> Windows 64 bit build issue.

3284e098e54c816c561ccb800d978b570f08c36e And forgot to merge ;( New release as 0.14 

My Comment -> This is a simple version number change from 0.13 to 0.14

98caea1496846935dd60a0e170c401e91ce9029a  And now it should work again on pypy 

My Comment -> Version change from 0.14 to 0.15, and build fix.

Comment 4 Kim 2015-04-27 22:39:22 UTC
Patch added and waiting for dependencies to be available. #1175527

Comment 5 Fedora Update System 2015-05-20 17:43:28 UTC
python-pylons-1.0.1-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-pylons-1.0.1-2.el7

Comment 6 Fedora Update System 2015-05-21 05:13:26 UTC
python-pylons-1.0.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository.

Comment 7 Fedora Update System 2015-06-18 18:33:59 UTC
python-pylons-1.0.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository.


Note You need to log in before you can comment on or make changes to this bug.