Bug 114228 - konqueror SIGABRT on first http addresss
Summary: konqueror SIGABRT on first http addresss
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-24 19:34 UTC by Peter Maas
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 18:44:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace of ABRT (4.42 KB, text/plain)
2004-01-24 19:35 UTC, Peter Maas
no flags Details

Description Peter Maas 2004-01-24 19:34:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
After starting KDE for the first time after rebooting the computer,
Konqueror SIGABRT's when viewing the first http page (es:
http://fedora.redhat.com) does not abrt on local files
(file:/usr/share/doc/HTML/index.html), it only does this one time, and
does not appear to cause any loss of functionality.

may or may not be related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=82081

including backtrace as attachment.





Version-Release number of selected component (if applicable):
kdebase-3.1.95-0.1

How reproducible:
Always

Steps to Reproduce:
1. Reboot computer, startx, launch konqueror
2. visit http webpage.
    

Additional info:

Comment 1 Peter Maas 2004-01-24 19:35:03 UTC
Created attachment 97238 [details]
Backtrace of ABRT

Comment 2 Ngo Than 2004-01-26 10:45:16 UTC
strange, i cannot reproduce this problem here, it works for me!

you mean it works again, if you start it a few times?

Comment 3 Peter Maas 2004-01-26 18:45:11 UTC
I only get the sigabrt the first time I view a http webpage with 
konqueror after rebooting the computer. After I close the kde 
backtrace application I can keep viewing in the same window.

It my be something related to my configuration with kde, Im going to 
remove all the preference files and see if the problem goes away.

Comment 4 Peter Maas 2004-01-26 20:56:14 UTC
The SIGABRT is being caused by a corrupted konq_history file. This 
appeared in kdebase-3.1.93-0.1.

In my .bashrc file i am 
rm -f .kde/share/config/konq_history
echo " " > .kde/share/config/konq_history
(I should have been 'touch'ing, but who know what I was thinking at 
the time.

This was creating a konq_history file with a size of 2 bytes. The 
first time a webpage is accesed konqueror looks at the file and 
SIGABRT's, the file then is written correctly and will not sigabrt 
until my user logs out and back in (.bashrc is executed again).

I have corrected the issue on my side, but this my be a sign of other 
problems with the file handling of konq_history.

You should be able to reproduce this problem by logging out of X, and 
replacing your konq_history file with a invalid one.



Comment 5 Peter Maas 2004-01-26 21:30:44 UTC
I think im going to recommend this bug for closing, after trying out 
the about steps as different user on the same computer, I was not 
able to replicate it myself, after removing the .kde dir for the user 
in question and reconfiguring kde I no longer see the problem, 
corrupt konq_history file or not.

Comment 6 Ngo Than 2004-02-05 18:44:37 UTC
i close this bug


Note You need to log in before you can comment on or make changes to this bug.