Bug 114238 - scroll mouse doesn't work
scroll mouse doesn't work
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-01-25 01:53 EST by Sean Middleditch
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-21 02:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sean Middleditch 2004-01-25 01:53:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
The scroll wheel on my USB scroll mouse does not work for scrolling,
altho clicking the wheel results in a button 3 click, as is expected.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install devel kernel
2. boot into X
3. use xev, cat /dev/input/mice, or just any app and try using the
scroll wheel    

Actual Results:  No scroll events are generated at all.

Expected Results:  Scroll events should be generated.

Additional info:

Previous kernels (kernel-2.6.1-1.34, iirc) worked perfectly fine with
the scroll wheel.  X packages have not been changed.
Comment 1 Sean Middleditch 2004-01-28 19:13:18 EST
just a note, this still doesn't work with kernel 2.6.1-1.61.
Comment 2 Sean Middleditch 2004-02-04 22:35:44 EST
According the kernel bugzilla, a patch is available - no mention where
that patch is, tho...  http://bugme.osdl.org/show_bug.cgi?id=329

Definitely still broken on kernel 2.6.1-1.65

And i'll stop spamming you now unless explicitly asked for more info.  ;-)
Comment 3 Sean Middleditch 2004-02-17 22:18:57 EST
Problem/fix found.

The uhci-hcd driver wasn't loaded, which is apparantly needed for full
mouse operation.  Whatever other driver was letting the mouse work
before handled everything except the scroll wheel, it seems.

I guess the fix would be to have the proper driver for the system load
by default without the user needing to hack on the modprobe.conf file.
 From reading the list archives (where I just chanced upon this fix),
it seems as if this problem is common.
Comment 4 Dave Jones 2005-01-10 23:57:52 EST
fixed in current trees ?
Comment 5 Sean Middleditch 2005-01-11 00:00:54 EST
I haven't encountered any problems on either of my test systems.  Seems to be

Note You need to log in before you can comment on or make changes to this bug.