Bug 1142385 - using results in --host-ca fails with Configuration key [https_ca] is not supported
Summary: using results in --host-ca fails with Configuration key [https_ca] is not sup...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: rpm-support
Version: 2.4.1
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-16 16:48 UTC by Preethi Thomas
Modified: 2015-02-28 22:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:20:47 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 532 0 None None None Never

Description Preethi Thomas 2014-09-16 16:48:59 UTC
Description of problem:
Repo create using --host-ca fails with Configuration key [https_ca] is not supported

Version-Release number of selected component (if applicable):
[root@qe-blade-13 ~]# rpm -qa pulp-server
pulp-server-2.4.1-0.8.beta.el6.noarch
[root@qe-blade-13 ~]# 


How reproducible:


Steps to Reproduce:
1. Create a repo with --host-ca value
2.
3.

Actual results:
[root@qe-blade-13 ~]# pulp-admin rpm repo create --repo-id=myRepo --host-ca /root/client.key --auth-ca /root/caPulp.crt --auth-cert /root/client.crt
The server indicated one or more values were incorrect. The server provided the
following error message:
 
   Configuration key [https_ca] is not supported
 
More information can be found in the client log file ~/.pulp/admin.log.


Expected results:


Additional info:




Sep 16 12:47:51 qe-blade-13 pulp: pulp.plugins.pulp_rpm.plugins.distributors.yum.configuration:ERROR: Configuration key [https_ca] is not supported
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: Exception adding distributor to repo [pulp2]; the repo will be deleted
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: Traceback (most recent call last):
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/cud.py", line 186, in create_and_configure_repo
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR:     distributor_id)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/distributor.py", line 184, in add_distributor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR:     raise PulpDataException(message)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: PulpDataException: Configuration key [https_ca] is not supported
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: Configuration key [https_ca] is not supported
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: Traceback (most recent call last):
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/exception.py", line 44, in __call__
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.app(environ, start_response)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/postponed.py", line 42, in __call__
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.app(environ, start_response)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 279, in wsgi
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     result = self.handle_with_processors()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 29, in _handle_with_processors
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return process(self.processors)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 566, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 581, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     result = handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.handle()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 230, in handle
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return self._delegate(fn, self.fvars, args)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 422, in _delegate
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return f()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 430, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     f = lambda: self._delegate_sub_application(pat, what)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 455, in _delegate_sub_application
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return app.handle_with_processors()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 29, in _handle_with_processors
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return process(self.processors)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 566, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 581, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     result = handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.handle()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 230, in handle
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return self._delegate(fn, self.fvars, args)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 420, in _delegate
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return handle_class(cls)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 396, in handle_class
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     return tocall(*args)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 227, in _auth_decorator
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     value = method(self, *args, **kwargs)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/repositories.py", line 166, in POST
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     repo = repo_manager.create_and_configure_repo(*args, **kwargs)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/cud.py", line 186, in create_and_configure_repo
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     distributor_id)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/distributor.py", line 184, in add_distributor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR:     raise PulpDataException(message)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware

Comment 1 Chris Duryee 2014-09-17 16:29:58 UTC
Need to investigate if option is ok to remove everywhere (cli, api, etc)

Comment 2 Preethi Thomas 2014-10-02 17:55:32 UTC
Looks like this is related to this bz 

https://bugzilla.redhat.com/show_bug.cgi?id=1119126

Comment 3 Brian Bouterse 2015-02-28 22:20:47 UTC
Moved to https://pulp.plan.io/issues/532


Note You need to log in before you can comment on or make changes to this bug.